Treppenstufenbeleuchtung

    So, es geht ein bisschen weiter.

    Da mittlerweile wieder Vorlesungszeit ist, habe ich leider nicht mehr so viel Zeit, mich mit dem Projekt zu befassen. Nichtsdestotrotz habe ich Fortschritte zu melden, ich habe die Auslöser für einzelne Treppenstufen fertig und auch schon gefertigt und getestet.

    Hier noch ein kurzes Video (auch wenn es aussieht, als würde ich drauftrampeln, es ist die normale Kraft, mit der ich die Treppe besteige. Beim Filmen siehts halt irgendwie steif aus):

    lF79BkHZmGI
    Bilder
    • DSC_0460.JPG

      99,28 kB, 1.024×635, 411 mal angesehen
    • Treppenlicht.png

      50,89 kB, 2.904×1.198, 507 mal angesehen
    Das sieht gut aus, aber der Schaltungsaufwand pro Sensor ist ja nicht ganz unerheblich....

    Hast Du mal an einen PIR-Sensor gedacht? Sowas wie hier: sparkfun.com/products/8630. Interface ist ein digitales Signal. Oder der 'nackte' Sensor: LHI 968 an einem Analogeingang. Vorteil: Weniger Schaltungsaufwand, man muss nichts direkt an/unter der Treppenstufe anbringen und die Erkennung funtioniert sehr zuverlässig. Die Module liegen bei ca. 5-10.-, die Nackten Sensore kosten bei Reichelt um die 3.-. Man kann das 'Sichtfeld' der Sensoren recht gut festlegen, indem man entsprechende Bereiche abklebt. So bekommt man einen schmalen Erkennungsbereich in Spaltform hin. Die Module habe ich schon im Einsatz, die funktionieren echt super und zuverlässig.
    Hi, danke für deine Vorschläge!

    Ich habe mir die Piezo-Vibrationssensoren auch ganz anders vorgestellt, ich habe nicht damit gerechnet, dass so viel Signalkonditionierung nötig ist, um das Signal für den Microcontroller bereitzustellen. Damit wird ein Sensor auch nicht mehr sonderlich billig wie geplant (2.50€ für Piezo + 1€ für ICs + Platinenmaterial und Kleinmist darauf...). Aber was solls :P

    Mit PIR habe ich schon mal herumgespielt. Mein Problem war bei dem Projekt, dass ich keine 10 PIRs unauffällig unterbringen kann. Unten an den Stufen erkennen die nix mehr, wenn man z.B. Schuhe an hat. Und eine Reihe auf Gesichthöhe sieht unästhetisch aus :)

    Der Beschleunigungssensor sieht gut aus, wusste gar nicht, dass es die so billig gibt. Nächstes Mal werde ich eh auf einen größeren µC umsteigen, dann werde ich bestimmt noch einen SPI/I2C Bus frei haben :D
    Ich brauche jetzt nur noch einen Reflow Ofen, um diese fiese Package löten zu können :thumbup:

    Squirrel schrieb:

    Hast Du mal an einen PIR-Sensor gedacht? Sowas wie hier: sparkfun.com/products/8630. Interface ist ein digitales Signal.


    Hi, nach all der Zeit nochmal auf dein Vorschlag zurück zu kommen: ich hab deinen Vorschlag aus Neugier doch tatsächlich mal ausprobiert, und es funktioniert erstaunlich gut!

    Ich habe aus DX einen ähnlichen Sensor bestellt, der weit unter 3€ das Stück kostet und mit dem bekannten IC BISS0001 arbeitet. Ich habe die Fresnel Linse entfernt und ein kleines Plastikrohr auf den PIR Sensor gesteckt, um den Erfassungswinkel einzuschränken. Standardmäßig ist das Modul sehr träge, dass der IC auf recht hoher Totzeit und geringer Empfindlichkeit eingestellt ist. Wenn man zwei Widerstände ändert, dann funktioniert das in der Tat besser als mit den Piezo Modulen.

    Ich habe das System übrigens inzwischen bei meinem Eltern eingebaut und liefere demnächst auf ein kurzes Video. Meinen Eltern reichen aber die Erkennung an den beiden Enden und so muss ich die anderen Haufen Sensoren auf meiner eigenen Treppe verbauen (jede Stufe ein anderer Sensor :D ). Für die PIR Module habe ich schon eine andere Verwendung (in Kombination mit einem digitalen RGB Streifen), wenn werde das gesondert vorstellen, wenn ich dazu komme ^^
    Hi grüss dich,

    sag mal hast du einen genauen Schaltplan von deinem kompletten Modul aus dem Video vom ersten Post? Ich kenn mich mit dem elektrozeug nicht gut aus, jedoch bin ich in der Lage die Pläne zu lesen und nachzubauen :) Wäre dir unendlich dankbar wenn du mir helfen könntest, da ich deine Idee/Lösung am besten finde! Und eine kleine Frage noch: Was für ein Netzteil hast du und welche Vorled's hast du genutzt? Wäre dir sehr dankbar wenn du nen reichelt Link schicken könntest :) oder deinen ersten Beitrag mit allen Komponenten updatest.

    Vielen dank im vorraus und schönen Tag noch! :thumbsup: :thumbsup:
    Hallo ich bin hier neu und möchte gerne bedanken.

    danke für so ein tolles Projekte
    Respekt
    ich habe sogar keine Worte für die leute wer in seinem Freizeit noch zeit für die andere findet und uns Anfänger solche Projekte zu präsentieren und erklären


    Respekt Respekt

    weiter so :thumbsup:

    iceananas schrieb:

    ... Ich habe das System übrigens inzwischen bei meinem Eltern eingebaut und liefere demnächst auf ein kurzes Video ...
    hallo ich wollte frage hast du schon video von treppenbeleuchtung deine Eltern
    und welche Sensoren hast du eingebaut ??

    danke für Antwort

    [ModEdit: völlig nutzlosen Fullquote eingekürzt ...]
    [ModEdit: Doppelposts zusammengefasst ...]

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Lötmeister“ ()

    Hallo Zusammen

    also ich habe das Projekt von Iceananas nachgebaut, habe soweit auch alles am leuchten gehabt
    nur funktioniert das ganze 2-3 mal und dann bleibt die Treppe dunkel.

    Ich hatte auch schon Kontakt mit Iceananas aufgenommen, ob er mir helfen könnte , das hat er auch getan (großen Dank dafür !)
    und wir haben viele Sachen getestet, nur leider ist er nicht mehr erreichbar und war auch schon lange nicht mehr im Forum unterwegs.

    Und nun brauche ich eure Hilfe:

    Zum Problem, wie oben geschildert lief das Programm nach der Anpassung auf die Ultraschallsensoren HC-SR2 mit der NewPing Single Pin
    library durch, aber das ganze halt nur 2-3 mal.
    Danach schickte mir iceananas ein Programm ohne schnick schnack wie fading usw. und ein paar Anpassungen dasselbe Problem
    Dann probierten wir ob die ultraschallsensoren richtig funktionierten das war der Fall, das Programm dafür sah so aus, das wenn ich nah am Sensor bin
    alle Treppenstufen leuchteten und je weiter weg ich ging dem entsprechend weniger Stufen leuchteten, so konnten wir davon ausgehen das durch
    den Sensor auch keine anderen Objekte erfasst wurden.

    So und nun weiß ich nicht weiter und meine Frau fragt ständig wann das nun fertig wird ;) da das Projekt mit Pausen schon ein Jahr läuft :)

    Danke für eure Hilfe und ein großes Danke nochmal an Iceananas

    Grüße
    Hm... für undefinierbares Verhalten würde mir noch die Brownout-detection einfallen - habt ihr das getestet? (bspw mit einem zusätzlichen Kondensator in der Stromversorgung des Arduino?
    Wenn jemand Futter für seine Haustiere (Hamster, Mäuse, Ratten, etc) braucht... Futterkrämerei - der Laden meiner Frau ;)
    Infos über Cree LEDs: pct.cree.com/
    Meine Projekte: [1] [2] [3]

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Fakrae“ ()

    Ich würde testweise mal einen 333uF-Elko verwenden (ähnliche gibt es auch bspw bei Conrad etc) und den (richtige Polung beachten) in die 5V Versorgung einbringen/löten. Am besten so nah wie möglich an den Arduino.

    Ich könnte mir vorstellen, dass das Schalten der MOSFets (für die Lichter) unter bestimmten Bedingungen die Spannung im Versorgungsnetz so weit sinken lässt, dass der Arduino kurzzeitig zu wenig Spannung hat - dadurch können viele interessante Dinge passieren ^^ Da es beim Arduino ziemlich viel Arbeit ist, die eingebauten Schutzmechanismen richtig ein zu stellen (der Arduino startet neu, wenn die Spannung unter 2,7V fällt - da kann es aber manchmal schon zu spät sein) ist es der bessere Ansatz die Spannung am Arduino zu puffern, um so zu verhindern, dass sie zu weit abfällt. Dafür ist der elko da, der dient als eine Art kleine Batterie (mit einer Standzeit <<1sek, aber das reicht idR aus) und liefert den notwendigen Strom, wenn es dein Netz nicht tut.
    Wenn jemand Futter für seine Haustiere (Hamster, Mäuse, Ratten, etc) braucht... Futterkrämerei - der Laden meiner Frau ;)
    Infos über Cree LEDs: pct.cree.com/
    Meine Projekte: [1] [2] [3]
    Ok danke für die gute Erklärung, hab mir jetzt einen bestellt und werde es nächste Woche gleich mal ausprobieren
    ob es funktioniert.

    bis dahin Grüße

    Hallo ich nochmal, habe noch einen 220uF-16V-105 Elko gefunden, würde der das zur Not auch tun? Grüße

    Hier ein Test mit Elko und Ultraschallsensorreichweite:dropbox.com/s/mvid97s8z8j1luh/20140628_100621.mp4
    habe das ganze auch mit dem normalen Programm getestet aber irgendwie hakt die ganze Geschichte

    So habe nochmal alles durchgewühlt und habe einen 220 25V 85C Elko gefunden wäre der besser?

    ich habe mal meine 3 Post´s zusammengefasst ;)

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von „EULE66“ ()

    So habe nochmal das original Programm drauf gespielt und getestet mit Elko folgende Beobachtung : ein Gegenstand habe ich direkt mit 15 cm vor den unteren Ultraschallsensor positioniert, das Programm läuft ohne Probleme ständig durch das heißt jede Stufe leuchtet so wie sie soll und jede geht genauso aus wie sie soll, nehme ich den Gegenstand aus dem erkennungsbereich bleiben alle Stufen aus, bringe ich den Gegenstand wieder auf die selbe Stelle startet das Programm nicht!
    An was kann das liegen?
    Hier das Video dropbox.com/s/ifjqujbxoizo68t/20140629_155013.mp4
    Grüsse

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „EULE66“ ()

    Die Elkos müssten auch funktionieren, ja - irgendwie hab ich deinen Post nicht gesehen gehabt ;/ Kannst auch mal die beiden parallel nehmen, dann hast du etwas mehr Kapazität.

    Und du hast exakt das gleiche Programm genommen wie Iceananas?
    Wenn jemand Futter für seine Haustiere (Hamster, Mäuse, Ratten, etc) braucht... Futterkrämerei - der Laden meiner Frau ;)
    Infos über Cree LEDs: pct.cree.com/
    Meine Projekte: [1] [2] [3]
    Hallo

    Also hab beide elkos zusammen in die Schaltung gebaut, das Ergebniss ist das selbe wie oben beschrieben.
    Das Programm ist nicht das original wie im Thread vom iceananas, sondern angepasst von ihm selbst, da ich die Ultraschallsensoren verwendet habe statt der ir Sensoren.
    Soll ich den Code mal posten?

    Gruß