WS2812 mit Jinx über Universal-Interface-Board via Art-Net

    WS2812 mit Jinx über Universal-Interface-Board via Art-Net

    Hallo in die Runde,
    habe hier ein Problem, vielleicht könnt Ihr mir weiter helfen. Ich habe eigene LED-Stripes mit WS2812B, welche mit der Software "Glediator 2.0.3" via Art-Net mit dem Universal-Interface-Board (my.agile-hardware.de/en/umsetzerboard) ansteuere. Das funktioniert auch soweit absolut super.
    Nun möchte ich auch die Software "Jinx!" zur Ansteuerung verwenden, auch dieses Programm stellt zur Datenausgabe Art-Net zur Verfügung. Ich habe alle möglichen Patch,- bzw. Konfigurationsversuche durchgeführt, leider ohne irgendeinen Erfolg ?( .Ich wundere mich nur warum nichts geht, denn Art-Net ist doch ein definiertes Standard-Protokoll.
    Hat jemand von euch eine Idee was da falsch läuft, für jeden Hinweis wäre ich äußerst dankbar!

    Dank und Gruß
    NN. aus Frankfurt/M
    Hi schorschi,

    wüsste nicht, warum das nicht funktionieren sollte. Was hast du denn in Jinx alles eingestellt ? Tut sich gar nichts oder klappt der Patch nicht (Jinx zählt grundsätzlich ab 0, also auch bei Artnet ist der erste Kanal in Jinx 0 und nicht 1) ?
    Ausgang gestartet ? Sprichst du direkt die Ip an oder machst du nen Broadcast ?

    Gib uns ein paar Infos, dann gehts leichter zu helfen.
    Nee, habe ja immer noch nicht viele Informationen. Was mir dazu aber einfällt:
    Jinx! - LED Matrix Control ... und die nächste Matrix Software ... (bei dem Link bitte 1 Beitrag hoch scrollen)

    Weiss nicht wie das inzwischen in der UIB Firmware aussieht. Auf welche Kanalzahl ist denn da das UIB eingestellt ? Wenn das immer noch so ist, dann nimmt das UIB nur Framegrößen an, wie sie im UIB hinterlegt sind. Dann musst du die Framegröße in Jinx natürlich auch anpassen. Wie hoch ist denn die Kanalzahl in Glediator eingestellt ? Das ist bei Artnet immer etwas schwammig. Eigentlich sollten volle Frames bei Artnet gesendet werden (512 Kanäle), was Jinx auch standardmässig macht. Laut Spec kann man auch weniger senden, die Anzahl muss aber durch 2 geteilt werden. Manche Programme senden wieviele sie wollen oder benötigen (Glediator z.B.) und dann kommt es auf den Empfänger an, was der mit einer Framegröße macht die nicht seiner eigenen entspricht. Wenn ich Pepe damals richtig verstanden habe, nimmt das UIB nur die Framegröße an, die im UIB eingestellt ist. Vielleicht liegt da der Hase begraben ....
    Hallo,

    Ich bin selber neu hier aber ich habe das gestern probiert, bei mir hat es am anfang auch nicht funktioniert da meine IP adresse und Subnetzmaske falsch waren..

    jetzt habe ich am PC : 192.168.0.10 SUB: 255.255.255.0 und auf der Karte habe ich 192.168.0.99 eingestellt, danach hat es funktioniert!
    Hast du bei JINX auch setup\start_output aktiviert?
    ... also zunächst zu meinem Projekt:
    LED-Panel mit 1008 (42x24) 2812B, in der vertikalen Mitte eingangsmäßig geteilt d.h. 504 Pixel für den oberen Bereich und 504 für den Unteren, schlangenförmig verdraht für jeweils 4 Universes a' 126 Pixel macht 378 DMX-Kanäle. Läuft mit GLediator über die UIB's echt top, auch mit meinem Gesamtaufbau 4 LED-Panel's (dann 84x42 Pixel) in 32 Universes gepatcht. Stromversorung für das Gesamtsystem 4x 5V/70A. Die UIB's sind IP-mäßig durchnummeriert X.X.X.141 - X.X.X.148 alle in einem CLass-C Netz.

    Nun zu den UIB's:
    Im Configurator unter "Mode&Protocols" lasst sich der Output nicht permanent auf WS2812 speichern, soll heißen nach erneuten Start des Configurator-Tool's und verbinden zu UIB ist beim Output wieder "Glediator" ausgewählt. Das gleiche mit der "Nichtspeicherbarkeit" habe ich bei "Parameter", hier gebe ich 378 ein, speichere ab, auch ins EEPROM und nach erneutem Start steht wieder 512 drin. Nach Rückfrage mit dem Hersteller wurde mir gesagt, dass das möglicher Weise ein Darstellungsproblem im Configurator sein könnte :whistling: . Zunächst habe ich dieser Sache keine große Gewichtung zugeteilt, da mit Glediator ja alles top funktioniert. Was im Bereich "Patch" eingetragen werden muss ist mir unklar, war bzw. ist auch anscheinend für Glediator unerheblich.

    @ LED_Joe: Output wurde aktiviert!
    -> Erweiterte Antwort -> Dateianhänge

    Ansonsten wie ich geschrieben habe. Bei Glediator hast du das Artnet auf 378 Kanäle stehen. Wenn es bei Glediator geht, dann ist das UIB auch auf 378 Kanäle eingestellt und nimmt vermutlich nur Frames mit 378 Kanälen an. Ist zwar nicht nach Spec, macht das UIB aber wohl so (siehe Post von Pepe den ich verlinkt habe, welcher übrigens auch der Entwickler des UIB ist).
    Also in Jinx bitte auch auf 378 Kanäle stellen (Im Output Device Channels von 512 auf 378 abändern), damit es auch kurze Frames erzeugt. Ich denke mal daran liegt der Haken. Genau dies hatte ich ja schon bei meinem zweiten Post gemeint und verlinkt.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Seddi“ ()

    ... sorry, hat leider auch nix gebracht!
    Außerdem läßt sich beim UIB der Wert 378, oder irgend ein Anderer, nicht abspeichern außer 512. Was meint den der Entwickler (Pepe) dazu???
    Ich habe acht UIB's a' (my.agile-hardware.de/de/umsetzerboard) Euro 89,00 (Euro 712,00) für gutes Geld gekauft. Man sicherte mir zu, dass die Teile voll ArtNet kompatibel seien, ... und jetzt lassen sich nicht mal die Parameter permanent abspeichern.

    Gibt es ggf. eine neuere Firmware für die UIB's? ... bzw. wie stelle ich fest, welche Version drauf ist???

    Ich hoffe sehr, dass Du vielleicht Licht ins Dunkle bringst!
    Besten Dank vorab!!!!!
    ... so, im Laufe der Woche hatte ich mal einen anderen Controller bestellt, deutsches Produkt - keine China-Ware und in Sachen Preis/Leistungsverhältnis der ArtNet-Funktionalität deutlich preiswerter. Was sofort sehr positiv aufgefallen ist, das Teil wurde von DiagnoseTools wie zB. DMX-Workshop, ArtNetominator, usw. sofort erkannt und war darüber konfigurierbar.
    Werde heute den neuen Controller umfangreich testen, Bericht folgt!!!!

    Schönen Wochenende!!!!
    Ich bin mir nicht sicher ob es dieses board die Daten per Artnet auf einem anderen Port ausgibt.
    Hast du die möglichkeit mit einem Netzwerkanalyseprogramm wie Wireshark dem Datenfluss am LAN port zu sehen wenn der Controller per Glediator läuft?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „CelsoSC“ ()