Buck-KSQ und PWM per Arduino

    Buck-KSQ und PWM per Arduino

    Hallo,

    Ich möchte diese LEDs mit dieser Mini Buck-KSQ betreiben und mit einem Arduino über den PWM Eingang der KSQ steuern. Ich schaffe es aber nicht die Teile so zu verdrahten, dass es funktioniert. Ich habe eine Skizze zu meiner Schaltung angehängt. Kann ich den Arduino überhaupt so einfach mit dem PWM-Kontakt verbinden?

    Nach meiner Vorstellung, müsste sich doch an den LEDs zumindest eine Veränderung zeigen, wenn ich am PWM-Kontakt eine Spannung anlege, oder diesen mit Masse verbinde ?(

    viele Grüße

    Leon
    Bilder
    • WP_20170205_14_21_43_Pro.jpg

      369,08 kB, 1.000×563, 130 mal angesehen
    Danke für die schnelle Antwort! Ich habe jetzt den Masseanschluss vom Arduino und von der KSQ verbunden (Minuspol von der Stromzufuhr des Boards mit Minuspol Netzteil). Die LEDs leuchten leider trotzdem durchgängig. Aber die Schaltung ist sonst in Ordnung? Dann würde ich davon ausgehen, dass vielleicht die Lötstelle bei PWM nicht in Ordnung ist, oder die KSQ beschädigt.
    Ähm, ich sehe gerade, das du vom Arduino nur 5V und GND beschaltet hast - aber keinen PWM Output?
    Ist das nur ein Fehler in der Zeichnung, der hast du wirklich so verdrahtet?
    Wenn du an den PWM Ausgang eine LED mit Vorwiderstand anschließt, ändert sich deren Helligkeit? Auch mal ohne die KSQ testen. Wenn die LED sich nicht in der Helligkeit ändert, dann ist schon was anderes faul.
    Für die Jüngeren: Led Zeppelin ist KEIN beleuchtetes Luftschiff! :D
    Hmm, leider tut sich dann nichts, sie leuchtet weiter wenn ich den PWM-Eingang auf Masse lege. Dann nehme ich an, dass es an der KSQ liegt, vielleicht habe ich sie beim verlöten beschädigt :| . Falls das nicht zu weit greift, weshalb muss ich die beiden Massen verbinden? Und schon mal vielen Dank für die Hilfe :)
    Wenn sich nichts tut, wenn du den PWM Eingang der KSQ auf Masse der KSQ legst, dann ist das in der Tat seltsam.
    Hast du zufällig den PWM Eingang mit dem Arduino schon angesteuert, als an der KSQ noch keine Spannung anlag? Das könnte die Ursache sein. Da die KSQ allerdings eine "Blackbox" ist und keine belastbaren Unterlagen, wie verbautes IC und ein Schaltplan existieren, ist das stochern im Nebel. Ich habe mir auf die genannte Art jedenfalls mal 4 selbstgebaute KSQs zerschossen, da sich das IC in Rauch auflöste. Kann freilich sein, das dagegen schaltungstechnisch Vorkehrungen getroffen wurden (z.B. durch einen Strombegrenzungswiderstand), aber solange darüber nichts bekannt ist, muß man erstmal vom ungünstigsten Fall ausgehen.
    Für die Jüngeren: Led Zeppelin ist KEIN beleuchtetes Luftschiff! :D