WS2812b LED Strip flackert

    WS2812b LED Strip flackert

    Hallo Forum,
    wir haben ein Problem mit unseren WS2812b LED Streifen.

    Wenn der Streifen mit voller Leistung in ROT oder GRÜN oder BLAU leuchtet (also mit dem Wert 255) flackert der Streifen nicht (sehr gut), aber sobald zwei Farben gemischt werden (z.B. r255 g100 b0) fängt der Streifen an unregelmäßig zu flackern.

    Wo ist unser Fehler?

    Unser Aufbau ist folgender:
    24V Netzteil (Erdung ist mit V- verbunden) --> 5V Step Down Modul --> BC-216 ARTNET-SPI controller​ (identisch zum AlphaPix Controller) --> GND vom Controller und V+ vom 24V Netzteil mit einem weiteren 5V Step Down Modul verbunden --> Elko 100µF 35V --> 1m WS2812b (Data kommt vom Controller, dazwischen sitzt ein 260Ω Widerstand)
    Der Controller wird über Ethernet und QLC+ gesteuert.

    Ich hoffe das ist verständlich.

    Danke für jede Hilfe!
    Hast du die Mögichkeit den Streifen mit einer anderen Signalquelle zu betreiben und zu steuern?
    Oder erstmal mit einem 5V Schaltnetzteil ohne die Stepdown-Wandler?

    So könnte man das ganze etwas eingrenzen. Von der Schaltung sieht das passend aus, allerdings kann ich mit "(Erdung ist mit V- verbunden)" nichts anfangen. Hast du also den V- Ausgang am 24V Netzteil mit dem Schutzleiter des 230V Netz verbunden?
    Es sind 60 Pixel und LEDs auf 1m Länge.


    Damit wäre das StepDown Modul ja dann schon ziemlich überlastet. Die "2A typical" sind wohl nicht wörtlich zu nehmen, sobald also die Last ansteigt (indem eine 2. oder 3. Farbe dazukommt) bricht die Spannungsversorgung ein.

    Oder erstmal mit einem 5V Schaltnetzteil ohne die Stepdown-Wandler?


    Das wäre in der Tat der erste sinnvolle Schritt der Fehlereingrenzung

    Also wenn ich ein 5V Netzteil statt des 24V Netzteil und der beiden 5V Step-Down Module nutze, flackert der Streifen tatsächlich nicht mehr.

    ​allerdings kann ich mit "(Erdung ist mit V- verbunden)" nichts anfangen. Hast du also den V- Ausgang am 24V Netzteil mit dem Schutzleiter des 230V Netz verbunden?

    Ja genau.

    Wir sind später auf längere Zuleitungen angewiesen, da wir das System modular auf eine Bühne verwenden wollen. Wir möchten eine 8m Zuleitung (3x 0,75mm²) vom Controller und 24V Netzteil zu den LED Streifen legen. Es werden dann fünf 1m Streifen sein die am anderen Ende angeschlossen sind. Jeder Streifen erhält sein eigenes 5V Step Down Modul. Data wird durch alle 5 Streifen durchgeschliefen.
    Geplant ist dieser Aufbau für ingesamt 20x 1m Streifen (also 4x 8m Zuleitung usw.)

    Gibt es sonst eine andere Möglichkeit lange Zuleitungen, sowie kaum Spannungsverlust zu haben? Die Kabel sollten idealerweise auch nicht zu dick werden, da wir XLR Stecker zum verbinden verwenden.
    Vielleicht (wenn das ganze schon für eine Bühne -live- sein soll) etwas mehr als 1,31€ für ein 2A Stepdownmodul ausgeben.

    Ich sehe keine Probleme wenn ein ausreichend dimensioniertes StepDown benutzt wird.

    //Warum verbindest du den Nulleiter mit dem V- ? Wie kommt man darauf?
    Über welche Entfernung sprechen wir denn bei den einzelnen 1m Streifen untereinander in einer Gruppe?
    kleine Rechnung:
    60LEDs/Meter a 3 Kanäle insgesamt also 3,6A für jeden Streifen.
    In einer Gruppe a 5 Streifen also ca. 20 A pro Gruppe.
    Da ist es eventuell sinnvoller jeder Gruppe ein eigenes 5V Netzteil zu spendieren und den Controller mit einem extra 24V Netzteil zu versorgen. So kann jedes 5V Netzteil recht nah an den Streifen platziert werden.
    Bei der Verwendung von einzelnen Step-Down Wandlern müssen diese ja schließlich 4A schaffen und das bleibt dann nicht bei 2€ für ein Modul.
    Netzteil

    Natürlich nur unter dem Annahme, dass die Leitungslängen der einzelnen Streifen untereinander nicht allzu lang sind. Manche Netzteile bieten ja auch die Möglichkeit die Spannung etwas nach oben zu korrigieren um eben diese Leitungsverluste auszugleichen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Hxg135“ ()

    Danke für die schnelle Hilfe bis hierher!

    60LEDs/Meter a 3 Kanäle insgesamt also 3,6A für jeden Streifen

    Das stimmt die 2A des StepDown Moduls reichen nicht für 60 Pixel. Wir haben da auch einen Fehler gemacht. Eigentlich wollten wir ein Modul für 50cm, also 30 Pixel, verwenden.
    Das habe ich jetzt einmal auch gemacht und siehe da, jetzt blinkt es so gut wie garnicht mehr. Aber leider hin und wieder dann doch einmal. Bedeutet es also das unser StepDown Modul dafür immer noch nicht ausreicht? Wahrscheinlich ja, oder?

    Da ist es eventuell sinnvoller jeder Gruppe ein eigenes 5V Netzteil zu spendieren

    Das ist für den Aufbau auf der Bühne keine wirkliche Option für uns, werden wir aber nochmal überdenken.

    Warum verbindest du den Nulleiter mit dem V- ? Wie kommt man darauf?

    Wir hatten die Erdung mit V- verbunden, damit wir über alle Netzteile hinweg die gleiche Masse haben. Die Info hatten wir irgendwann wo erlesen, aber wenn ihr sagt das braucht man nicht zu machen, lassen wir es gerne weg.

    Hxg135 schrieb:

    Manche Netzteile bieten ja auch die Möglichkeit die Spannung etwas nach oben zu korrigieren um eben diese Leitungsverluste auszugleichen.


    Damit wäre ich vorsichtig! Wenn der Spannungsabfall bei Vollast passt, kann es durchaus sein, das wenn nur wenige Pixel leuchten, die dann durch Überspannung zerstört werden. Dazu bräuchte es Netzteile mit 3 oder 4 Leitertechnik, wo eine Sense Leitung bis zum Stripe mitgeführt wird, so das je nach Stromaufnahme die Spannung dynamisch so angepasst wird, das hinten immer 5V ankommen.
    Zum einen würde ich kleine Low ESR Elkos mit 1000µF oder mehr und 6,3oder besser 10V Spannungsfestigkeit nehmen. Oder wenn du auch mit frickeligen SMD Bauelementen klar kommst, würde ich auch mal 100µF 6,3 oder 10V KerKos probieren. Die kann man sogar relativ unauffällig auf den Stripe löten. 100n sollten ohnehin an jedem Pixel sein. Wenn das nicht reicht, dann trenne mit einem Skalpell den Pluspol in der Mitte auf uns speise jeweils 50 cm von oben und unten mit einem extra Modul ein. Ich würde aber die Trimmer aus den Modulen rauswerfen und gegen 2 jeweils Festwiderstände als Spannungsteiler ersetzen. Wenn da ein Trimmer spinnt, zerlegt es dir ungünstigstenfalls das entsprechende Segmet. Die Step down Module sind zwar nicht optimal, aber bei dem Preis kann man auch ein paar mehr nehmen und das Problem mittels Masse erschlagen.
    Sicherlich ginge ein optimal designtes Modul mit 3A Ausgangsstrom (lt Datenblatt der maxiamalstrom vom LM2576 und LM2596), aber man kann nicht alles haben ;)
    Für die Jüngeren: Led Zeppelin ist KEIN beleuchtetes Luftschiff! :D
    Das Problem ist gelöst! Danke für die super Hilfe!

    Zum einen würde ich kleine Low ESR Elkos mit 1000µF oder mehr und 6,3oder besser 10V Spannungsfestigkeit nehmen.

    Mit dem Elko mit 6,3V gab es noch extrem selten, leichtes flackern einzelner LEDs.
    Aber mit der 10V Version ist kein einziges flackern mehr zu sehen! Perfekt!
    Und noch der Vollständigkeitshalber, das StepDownModul ist jetzt nur noch für 50cm zuständig (wie es ursprünglich auch berechnet wurde).
    Die 10V Version wird deswegen funktionieren, weil Elkos gleicher Kapazität, aber höherer Spannung meist einen kleineren ESR haben. Es ist dann aber immer noch sehr knapp auf Kante genäht. Spendiere den einzelnen Step Down Modulen unmittelbar am Eingang noch einen 35V Elko mit 1000µ low ESR, damit die Module bei Belastung nicht zusammenbrechen und auch liefern können.
    Und immer schön auf sternförmige Verkabelung achten. Die Elkos nahe da hin, wo sie puffern sollen und am Elko trifft sich Stomversorgung und Verbraucher. Es ist witzlos einen Elko T-förmig anzuschließen, da die Leitung bis zum Kontenpunkt seinen ESR erhöht.
    Für die Jüngeren: Led Zeppelin ist KEIN beleuchtetes Luftschiff! :D