unbekanntes Solarpanel mit Schaltung

    unbekanntes Solarpanel mit Schaltung

    Hi!
    Ich hoffe, ich bin hier im richtigen Forum. Wenn nicht, bitte Info, wohin mein Thread hinverschoben wurde...

    Ich habe ein mir unbekanntes Solarpanel mir einer Schaltung siehe Bild. Ich habe hierzu nichts weiter im Internet gefunden. Ich weiss nur, dass dass an B+ und B- ein 6V Akku angeschlossen werden soll. Mache ich das, passiert leider nichts. Das Panel liefert etwas mehr als 6V, funktioniert also. Ich habe jede LED einzeln getestet, funktionieren auch. Wird das Panel abgedunkelt, leuchtet keine LED, Akku ist definitiv voll geladen.
    Auf dem Chip steht leider nichts drauf.

    Kann mir jemand helfen?

    Danke!
    Bilder
    • panel_1.jpg

      286,25 kB, 1.920×1.440, 59 mal angesehen
    B- verläuft, soweit ich das erkennen kann, im Nirgendwo - versuch s mal mit dem GND-Lötpad

    Ich würde aussdem checken, wie warm R7 wird - über den läuft das alles, je nach Helligkeit kann der schon sehr heiß werden.
    A Christian telling an atheist he is going to Hell is about as scary as a small child telling an adult they wont get any presents from Santa.
    Bin kein RGB-Freund
    B- läuft an C6 und einem Pin von Q3 (beide sind leider nicht belegt). R7 scheint i.O. zu sein. Ich messe einen Widerstand Ist also nicht durchgebrannt. Schliesse ich den Akku an GND und B+ an, nichts.
    Jetzt habe ich mal die Kontakte K1 ausgetestet und siehe da, es funktioniert! Allerdings gibt es vier Schaltmodi: 1) low light, high light, blinkendes Licht und aus.
    Bei einer Solarlampe blinkend ist eher ungewöhnlich. Ich möchte maximal zwischen low und high schalten... Am besten nur high.
    Aber wie??
    Fällt Licht auf die Solarzellen, bleiben die LED´s eingeschaltet. Das Loch in der Mitte der Platine lässt mich vermuten, dass entweder ein LDR o.ä. oder ein Schalter verbaut werden muss.

    Ohne Details kommt man nicht weiter, oder? Welche Infos benötigen die Spezies aus dem Forum? Ich würde das Teil gerne nutzen...

    Danke!
    Also, habe noch ein paar Messungen durchgeführt. Insbesondere Q6, da ich nicht weiss, ob NPN oder PNP. Bei beiden Typen ist der PIN in der Mitte der Emitter (nach Datenblättern, die ich gefunden habe). Halte ich mein Multimeter als Durchgangsprüfer an B+ und E leuchten alle LED´s sehr schwach. Der rechte PIN gibt Durchgang bei GND. Akku ist nicht angeschlossen, Solarpanel ist verdeckt und erzeugt keine Strom.

    andreas schrieb:

    Also, habe noch ein paar Messungen durchgeführt. Insbesondere Q6, da ich nicht weiss, ob NPN oder PNP.


    Vermutlich weder noch, sondern ein Mosfet der die LED Kathode auf GND zieht.

    Wenn das geht wegen IC: mit einem Widerstand, 10k oder so, das Gate auf Plus gezogen, müssten die LEDs bei beleuchtetem Panel leuchten.

    Wenn B- nur an nicht bestückte Bauteile geht, war die Batterie vermutlich direkt an S- (oder noch woanders) angeschlossen. Was für einen Akku hast du denn dazu?

    andreas schrieb:

    Schliesse ich den Akku an GND und B+ an, nichts. Allerdings gibt es vier Schaltmodi: 1) low light, high light, blinkendes Licht und aus.


    Woher weißt du das denn? Was ist nichts? Ich kann anhand deiner Info selten erkennen ob du das jetzt
    a) über Tests (was genau) herausgefunden hast,
    b) woanders her weißt, oder
    c) Eingebung ist.

    Darauf aufbauend meine Vermutung: der IC ist ein Prozessor, der nur die Schaltmodi der LEDs steuert, Bezeichnung bringt dich also wenig weiter.

    Nutzen kannst du es vermutlich ganz einfach: Ersetze Q6 mit einem Schalter.
    Hi!
    Wie ich oben geschrieben habe, ist der IC nicht beschriftet. Auf Q6 steht nur Y1. Wie ich seit heute weiss, könnte es sich um einen SS8050 oder SS8550 Transistor handeln (habe eben nochmal gegoogelt und in einem anderen Forum (Fahrradforum) gab es die Antwort. Der dort gepostete Link zum Datenblatt führte allerdings ins Leere).

    Ich verwende einen Akku bestehend aus 4 in Reihe geschalteten NiCd-AA-Akkus.

    Zu den Schaltmodi: Der Akku ist an GND und B+ angeschlossen. Nichts leuchtet. Brücke ich jetzt 1x die Kontakte K1 (am eckigen Loch) (also 1x wie ein Taster kurz gebrückt und dann Kontakt losgelassen), leuchten die LEDs, brücke ich ein zweites Mal (also den Taster ein zweites mal betätigen), leuchten die LEDs deutlich stärker. Mache ich das ein drittes Mal, blinken die LEDs. Mache ich das ein viertes Mal, schalte ich die LEDs aus. Ein fünftes mal und es beginnt von vorne. Das war eine Eingebung, das mal so zu testen. Allerdings ist das unabhängig von einem Lichteinfall auf das Panel. Ob mit oder ohne Sonne....

    Wenn ich das auf der Leiterplatte richtig verfolgt (und mit einem Durchgangsprüfer gemessen) habe, ist GND = S-

    Wenn das geht wegen IC: mit einem Widerstand, 10k oder so, das Gate auf Plus gezogen, müssten die LEDs bei beleuchtetem Panel leuchten.​

    Hier stehe ich auf dem Schlauch. Wo ist das Gate beim Q6? Und wie sollte ich Q6 durch einen Schalter ersetzen? (einer der beiden K1-Kontakte geht an einen PIN von Q6).
    Ich krieg die Motten, jetzt schreibe ich den Text zum 3ten Mal X(

    andreas schrieb:


    Ich verwende einen Akku bestehend aus 4 in Reihe geschalteten NiCd-AA-Akkus.


    5? 4 Zellen = 4,8V

    andreas schrieb:

    Auf Q6 steht nur Y1. Wie ich seit heute weiss, könnte es sich um einen SS8050 oder SS8550 Transistor handeln (habe eben nochmal gegoogelt und in einem anderen Forum (Fahrradforum) gab es die Antwort. Der dort gepostete Link zum Datenblatt führte allerdings ins Leere)..


    NPN-Kleinsignaltransistor secosgmbh.com/datasheet/produc…nsistor/SOT-23/SS8050.pdf

    LDR war vermutlich nie geplant, zu teuer. Die LEDs leuchten auch bei Sonnenschein, Strom gibt es ja dennoch.

    andreas schrieb:


    Hier stehe ich auf dem Schlauch. Wo ist das Gate beim Q6? Und wie sollte ich Q6 durch einen Schalter ersetzen? (einer der beiden K1-Kontakte geht an einen PIN von Q6).


    Gate/Basis ist der Pin, der (eventuell über R11, ich seh das nicht genau) an den IC geht.

    K1 sollte mit Q7 nur als Teil des Massenetzes verbunden sein.

    Aber das ganze sieht man im Bild nicht genau, es wäre schön wenn du mal mit den Bauteilen (nur bestückt) einen Schaltplan zeichnest.

    Meine Vermutung ist, der Schalter (eigentlich Taster) triggert nur die 4 Modi des ICs. Nur auf Ein/Aus umbauen ist über den IC nicht möglich.
    Der Schalter (nicht Taster) müsste an GND und Kollektor des Q7 (der linke einzelne Pin), bzw. das verbundene Netz gelötet werden.