Angepinnt Cube 3x3x3 leicht gemacht (mit Fotos und Schaltplänen)

    :D Hallo Würfelfreak's :D

    Sehr schön. So hätte ich das vieleicht auch aufziehen sollen. Das Prog ist ja mal um längen besser als meins. Ich wollte ursprünglich es auch wie Du machen und die LED'S in der Grafik anklicken. Ging aber nicht weil VBasic nicht soviele Steuerelemente in einer Form Akzeptiert. Bei 255 ist Schluß. Ärgert mich ein wenig, weil es wie es jetzt ist ist es zu unübersichtlich. Aber da find ich noch eine Lösung. Hoffe ich ;( .

    PS: Kann man den Sourcecode haben? Bitte, bitte, bitte. 8o
    :thumbsup: Ein Killowatt sind zwei Pfund Strom :thumbsup:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „tipfix“ ()

    auch von mir erstmal ein lob. super arbeit.

    ich will mir zwar keinen cube bauen (bis jetzt :) ) habe aber mit hilfe eurer programme mit eine kleine matrix realisiert.
    immoment ist das noch eine 5x3 matrix. die würde ich jetzt aber gerne auf eine 5x4 matrix erweitern.

    pesi du hast ja auf der ersten seite auch schon ansetzte für einen 4x4x4 cube geschrieben ( Data &B00010000, &B00000000, &B00000000) wobei für mich die dritte spalte ja uninteressant wäre.
    aber was ich noch nicht ganz verstanden habe ist, mit diesem teil "0100" steuerst du ja die ports PD4, PD5 und PD6 an, wenn ich das richtig verstehe. je nachdem wo die eins steht.
    nur an welche ports müsste ich jetzt meine 4 zeile hängen, damit ich die dann über "0001" steuern kann ?? einfach alle einen "hoch" schieben ?
    also zeile eins an PD3, zeile 2 an PD4, zeile 3 an PD5 und zeile 4 an PD6 ??

    und noch ne sache. spielt es eine Rolle ob das B in der data zeile groß oder klein geschrieben ist ? denn in der muster.txt ist in der dritten zeile das B immer ein kleines b. vorne in deinem beispiel hast du aber alle 3 B's groß geschrieben.

    und weil ich schon grad dabei bin vlt noch ne kleeeine frage :)
    ich würd die matrix gerne vergrößern. also nicht die matrix an sich sondern die pixel. also es sollen 4 leds gleichzeitig pro matrix punkt leuchten.
    könnt ihr mir da helfen was für einen transistor ich brauche ??


    sorry für die vermutlich noob fragen, aber ich bin noch ein anfänger in sachen uC und danke für eure hilfe

    mfg Flipp

    edit: danke fightclub für deine erläuterungen und sorry das ich hier gepostet hab. dachte es wäre ok da es auch ums verständnis des programms ging.
    muss jetzt warten bis die noch benötigten teile kommen. könnte sein das ich dann och ne frage zum programm hab ;)
    mach dann aber nen neuen thread auf

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „flipp86“ ()

    @flipp86: Ich antworte jetzt noch hier, aber bitte dann nicht dadrauf antworten, sondern erstell bitte nen neuen Thread dafür, das hat hier eigentlich nicht so viel zu suchen, da es sich ja nicht um den Cube handelt. Hier sollen ja nur Fragen zum Cube rein!

    Wenn du deine 4. Zeile an PD7 hängst kannst du die in den Mustern über "1000" ansteuern "0100" wäre dann sinvollerweise die 3. Zeile, also PD6, "0010" = PD5 wäre dann die 2. Zeile und "0001" an PD4 die 1. Zeile. Das kannst du natürlich auch anders machen, war jetzt nur ein Beispiel. Das ganze hat Pesi auch kurz im seinem Post angerissen, da werden dann nämlich die 4 msb (most significant bit) angesprochen und für die Ebenen, in deinem Fall Zeilen verwendet. Denk dran dass du dann für die 4. Zeile noch eine weitere Datazeile brauchst und damit der counter im Programm dann ja noch etwas modifiziert werden muss.

    So wie es aussieht funktionieren die Muster ja, daher scheint es egal zu seinob kleines oder großes b. Ist dann halt ein Tippfehler in der Software.
    Ein passender Transistor wäre z.B. BC548.
    worfür du eine matrix brauchst ist dir ja hoffentlich klar oder? da kannst du laufschriften, animationen, bilder etc. anzeigen lassen... sieht man auch mittlerweile recht oft im fernsehen bei konzerten oder so.
    ein cube ist in dem sinne eigentlich "nur" eine 3d-matrix, wo du eben 3d-animationen abspielen kannst.. um dir ein kleines bild von dem ganzen machen zu können rate ich dir mal bei youtube zu stöbern, oder direkt hier herumzuschnuppern.
    die cubes hier im forum sind momentan noch einfarbig, die auf der verlinkten seite sind allerdings in rgb
    Hi,

    hatte die Frage erst Pesi persönlich geschickt und publiziere sie auf sein Anraten nochmal hier öffentlich.

    Ich find die Idee mit dem LED-Cube total klasse und hab mal versucht, mir den Schaltplan gedanklich anzueignen. Bin allerdings nicht so der Hellste auf dem Gebiet und hätte da jetzt ein, zwei Fragen dazu.

    (Besagter Schaltplan: ledstyles.de/index.php?page=At…320f7f045e11838b113fe8373)

    Ich komm denn also direkt mal zur Frage. Auf PB719, PB618, PB517, PB416, PB315, PB214, PB113 und PB012 wird die Spannung für die LEDs gelegt? Nehmen wir an, ich will die LED in der mittleren Ebene der Säule 5 zum Leuchten bringen. So wie ich das verstanden hab, sollte das ja möglich sein. (LEDs einzeln leuchten lassen) Dazu wird auf PB416 eine Spannung gelegt? Liegt dann auf PD0 Masse? Warum leuchten dann die LED Säule 5 obere Ebene und untere Ebene nicht?

    Köntte das vllt. jemand mal beispielhaft erklären?

    Entschuldigt bitte meine unglaubliche Blödheit, interessiert mich nur.

    Viele Grüße!
    Markus
    Hallo Markus, erst mal willkommen im Forum!

    das ist keine blöde Frage, jeder fängt mal irgendwie an...

    1. der PortD0 ist nix "besonderes", der hat die selbe Funktion wie PortB0-7: da hängt ne Säule dran (siehe Schaltplan) - da der Cube halt 9 Säulen hat, aber ein Port nur 8 Pins, wird für eine Säule eben der PD0 benutzt...

    2. Der "Witz" an der Sache ist der PD4-6 und die Anordnung als Matrix. Dazu auch die Transistoren unten (wegen dem "hohen" Strom, vom Prinzip her würde das auch ohne gehen). Und das geht so (Dein Beispiel):

    Ich gebe auf dem PB4 "1" aus, dann liegt der auf 5 Volt. Soll nun nur die LED in der mittleren Ebene leuchten, gebe ich auf dem PD5 auch "1" aus, dadurch schaltet der Transistor für diese Ebene durch, der Strom kann also von PB4 über den Vorwiderstand, die LED in der Mitte des Cubes und den Transistor nach GND fließen, die LED leuchtet.

    Die anderen beiden Transistoren sind gesperrt, daher kann in der oberen und unteren Ebene kein Strom durch die LEDs fließen, also leuchten diese auch nicht!

    3. Da man ja nicht nur LEDs einzeln anmachen will, funktioniert das Ganze so:

    Ich schalte die oberste Ebene "frei" (also PD6 = "1", der Transistor schaltet durch) und gebe an PB0-7 und PD0 das "Muster" aus, das in dieser Ebene angezeigt werden soll (also überall "1" wo die LED leuchten soll).

    Kurz darauf (ein paar ms) wird die Ebene 1 wieder gesperrt, dafür Ebene 2 "aktiviert" und an PB0-7 und PD0 das "Muster" ausgegeben, das diese Ebene anzeigen soll.

    Genauso für die 3. Ebene und dann das Ganze wieder von vorne.

    Das geschieht so schnell, dass das Auge es nicht mehr trennen kann, und nur ein Muster auf dem gesamten Würfel sieht. Das Ganze nennt man dann "Multiplex-Ansteuerung".

    Übrigens: DAS ist eine blöde Frage:

    derprof schrieb:

    Hallo,
    die ganzen Tools und Tutorials sind ja super , aber ich frgae mich gerade was kann ich mit so einem Würfel machen.
    Prof: Du kannst mit Hilfe dieses Würfels die Weltherrschaft erringen!


    Also, (sorry, in Bayern sagt man so) was für ein verblödeter Hornochse!
    It's only light - but we like it!

    Da es sich in letzter Zeit häuft: Ich beantworte keine PNs mit Fragen, die sich auch im Forum beantworten lassen!
    Insbesondere solche von Mitgliedern mit 0 Beiträgen, die dann meist auch noch Sachen fragen, die bereits im entsprechenden Thread beantwortet wurden.
    Ich bin keine private Bastler-Hotline, technische Tipps etc. sollen möglichst vielen Lesern im Forum helfen!
    so ich bins nochmal. ich post nochmal in diesem thread weil es denke ich schon eher um die schlatung geht als um was neues. hoffe ich krige kein aufs doch :whistling:

    ich hab mir jetzt genau die schaltung nachgebaut (nur halt in ner 5x3 matrix angeordnet).
    so funktionieren tut es im prinzip auch alles. ich kann alle leds ansteuern usw.
    allerdings flackern die.das heisst es sieht nicht so aus als ob die leds leuchten sondern sie flackern hin und her. und das nicht nur ein bisschen, sondern ziemlich deutlich.

    kann mir da jemand helfen ?? was hab ich falsch gemacht ?
    hab ich die transistoren falsch angeschlossen so das der pulsstrom nicht hoch genug ist ??

    mfg Flipp

    flipp86 schrieb:

    so ich bins nochmal. ich post nochmal in diesem thread weil es denke ich schon eher um die schlatung geht als um was neues. hoffe ich krige kein aufs doch :whistling:

    ich hab mir jetzt genau die schaltung nachgebaut (nur halt in ner 5x3 matrix angeordnet).
    so funktionieren tut es im prinzip auch alles. ich kann alle leds ansteuern usw.
    allerdings flackern die.das heisst es sieht nicht so aus als ob die leds leuchten sondern sie flackern hin und her. und das nicht nur ein bisschen, sondern ziemlich deutlich.

    kann mir da jemand helfen ?? was hab ich falsch gemacht ?
    hab ich die transistoren falsch angeschlossen so das der pulsstrom nicht hoch genug ist ??

    mfg Flipp
    Wenn du alles richtig ansteuern kannst, würde ich auf Probleme beim Timing tippen.
    Passen die Zeiten zur Taktfrequenz :?: Nicht das du die Zeiten für 8MHz Takt eingestellt hast aber den µC mit 1MHz laufen lässt ;)
    Sämtliche Angaben ohne Gewähr und ohne Anspruch auf Vollständigkeit!
    Flipp: Dein Tiny läuft zu langsam, der ist ab Werk auf 1 MHz eingestellt - Du musst den auf 8 MHz stellen - guckst Du hier, so die Fusebits einstellen.. wichtig: *erst Fusebits lesen*, dann so hinklicken (eigentlich nur den Haken bei CKDIV8 rausmachen), dann Fusebits wieder schreiben...

    Execute: Du bist doch schon lang genug hier ...Benutze die Suchfunktion, da gibt es wirklich 1.000 Beiträge dazu - wie schon gesagt, das hat nichts mit dem Cube direkt zu tun, solche grundlegenden Fragen gehören hier nicht rein!
    It's only light - but we like it!

    Da es sich in letzter Zeit häuft: Ich beantworte keine PNs mit Fragen, die sich auch im Forum beantworten lassen!
    Insbesondere solche von Mitgliedern mit 0 Beiträgen, die dann meist auch noch Sachen fragen, die bereits im entsprechenden Thread beantwortet wurden.
    Ich bin keine private Bastler-Hotline, technische Tipps etc. sollen möglichst vielen Lesern im Forum helfen!
    Ist doch kein Problem! - und schön, dass es jetzt funktioniert! :thumbup:
    It's only light - but we like it!

    Da es sich in letzter Zeit häuft: Ich beantworte keine PNs mit Fragen, die sich auch im Forum beantworten lassen!
    Insbesondere solche von Mitgliedern mit 0 Beiträgen, die dann meist auch noch Sachen fragen, die bereits im entsprechenden Thread beantwortet wurden.
    Ich bin keine private Bastler-Hotline, technische Tipps etc. sollen möglichst vielen Lesern im Forum helfen!
    Hallo Pesi! :)
    Nach einem kleineren Problem mit der Rechentechnik melde ich mich zurück...

    Man konnte das Klicken in meinem Kopf deutlich hören, so gesehen mit der Erklärung erscheint mir das ganze dann auf einmal auch logisch, doch ohne ging's ja doch nicht ganz. *grins*

    Auf jeden Fall vielen Dank! Wird in einem geeigneten "Moment" ganz bestimmt von mir nachgebaut!

    Viele Grüße!
    Markus
    Hab nen AT90S1200 gekriegt hab mir irgendwie gedacht das es nicht ATTINY sein kann.

    Hab gegoogled und gefunden das der weniger speicher hat usw.

    Ist in SMD bauform hab versucht den per ISP zu beschreiben hat irgendwie nicht ganz geklappt hab miso mosi sck reset vcc und gnd angeschlossen hat nicht geklappt.

    Mit dem Atmega8 hats auf Anhieb geklappt.