Glediator - Freeware LED Matrix Steuerung - Software

    Ich würde gerne mit dlediator laufen RGB-Tube.
    Hier ist der Zeitplan der Kanäle RGB-Tube :
    Wert 0 : Pixelmodus – Jede LED kann mit 3 Kanälen (Rot, Grün, Blau) angesteuert werden. Die
    Tube belegt damit 97 Kanäle.

    Kanal 1 Modus / Reset
    Kanal 2 LED1: Helligkeit rot
    Kanal 3 LED1: Helligkeit grün
    Kanal 4 LED1: Helligkeit blau
    Kanal 5 LED2: Helligkeit rot
    Kanal 6 LED2: Helligkeit grün
    Kanal 7 LED2: Helligkeit blau
    …..
    Kanal 97 LED32: Helligkeit blau

    Danke im Voraus für Ihre Antwort!
    Moin MOin ,
    gelötet ist nun alles .
    Die SW hab ich versucht einzustellen ..
    Was ich festgestellt habe das es hauptsächlich blau ist was man sieht .. so gut wie kaum grün und kein rot .
    Kann mir jemand bei der Fehlersuche behilflich sein ?
    Netzteil 5V ,300mA, 1,5 A

    Settings : 16 X 8 Y
    Output Glediator Protokol , vertikal wise , Com3 , Baurate 115200

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Pete the Beat“ ()

    Ich nehm mal an du arbeitest auch mit der Matrix Platine von Solderlab ? Wenn ja, Software auf dem Atmega auf die Baudrate angepasst ?
    Sieht mir nicht danach aus. Wenn du Daten mit 115200 schickst und die Steuerung erwartet 1000000 klappt das einfach nicht.
    Ansonsten könnte natürlich noch alles mögliche nicht passen, ist aber ohne weitere Infos/Bilder nicht zu erraten.
    Halli Hallo,

    ich habe nun das USB2Serial angeschlossen.
    Ist es richtig das der PC das als Arduino Uno erkennt ?

    Habe aber immer noch Probleme, das richtige Setting zu finden.
    Kann mir evtl. jemand sagen, welche Jumper gesetzt werden müssen?

    Danke


    NACHDEM der ältere PC immer gehackt hat,
    bin ich nun auf dem Laptop .. wo Glediator leider keine Com Ports anzeigt


    [ModEdit: Doppelposts zusammengefasst ...]

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Lötmeister“ ()

    Hi Saw,

    RXTX ist installiert ( in die Bin und Lib) kopiert .
    Hab ich nach der Anleitung hier aus dem Thread gemacht .
    FTDI ? Lese ich jetzt zum ersten mal .
    ICh habe sowohl auf dem Laptop als auch auf dem PC Win XP.

    Im Moment habe ich eine 16/8 Matrix gebaut .
    Nur weiss ich auch nicht so richtig welche Jumper ich setzten soll und welche nicht

    Die Com Ports habe ich jetzt am Laufen .. hab noch mal die RXTX kopiert .
    Nur kommt nichts zum Leuchten ausser Vertikal die beiden mittlersten Reihen eine blau eine grün

    Wenn ich 100000 Baut einstelle bleibt das Prog stehen
    Also erstmal zum USB2Serial Light, den passenden Treiber bzw. die inf Datei bekommst du hier: arduino.cc/en/uploads/Main/Arduino_USBSerial.zip
    Das ganze meldet sich dann glaub ich als Arduino Uno oder so ähnlich an (gerade nicht zur Hand das Teil), also soweit müsste das eigentlich geklappt haben bei dir. RXTX für Windows lädst du dir am
    besten hier herunter: cloudhopper.com/opensource/rxtx/
    Entweder Windows-x64 oder Windows-x86 je nachdem welche Java Version bei dir läuft (also auch wenn du ein Win7 64 Bit hast aber Java 32 Bit installiert hast, ist wohl bei den meisten der Fall und auch
    der Standarddownload bei Java gibt dir die 32Bit Version, musst du auch die 32 Bit RXTX verwenden). Aus dem Zip File nimmst einfach nur die RXTXSerial.dll und kopierst diese in dein Glediatorverzeichnis
    parallel zur Geldiator.jar (nicht in das Unterverzeichnis lib!!!) und dann sollte das mit der seriellen Schnittstelle prinzipiell klappen.

    Als Matrix Elektronik geh ich davon aus das du die Platine von Solderlab nutzt (meine Frage diesbezüglich blieb ja bisher unbeantwortet), also dafür im Glediator in die Preferences unter Matrix Options
    die Pixelanzahl einstellen (16x8 ), unter Output 1 Glediator Protokol und als Mapping Mode "Boards of Pixel" auswählen sowie die reihenfolge je nachdem wie du deine Matrix verdrahtet hast (ist zum testen
    aber erstmal zweitrangig). Danach auf Output 2 und die Com Schnittstelle auswählen sowie die Baudrate auf 1000000 setzen. Jetzt ERSTMAL Apply Changes machen BEVOR du Serial Open drückst, sonst
    sind die Einstellungen noch nicht aktiv. Mit etwas Glück hast du dann auf deiner Matrix ein paar leuchtende Pixel ;)

    Wenn nicht kann alles mögliche nicht passen. Ist der USB2Serial richtig mit der Platine Verbunden (RX/TX/GND) ? Ist die Platine in Ordnung (selber gelötet ? fertig gekauft ? Wenn Atmega selbst geflashed:
    Software auf dem Atmega sauber drauf, alle Flags gesetzt ? Verkabelung zwischen Platine und Matrix geprüft ? Keine kurzschlüsse auf der Matrix ? Nichts verpolt ? Netzteil bringt saubere 5V und genügend
    Dampf (2A sollte es schon schaffen bei 5V für deine 16x8 ) ?

    Wie gesagt da sind viele Punkte wo es klemmen kann, gib uns mehr Infos/Bilder/Details und wir können dich vielleicht auch in die richtige Richtung weisen.

    Ach ja, die beiden Reihen die vertikal bei dir leuchten haben vermutlich eine defekte LED, die nicht mehr sperrt. Somit leuchten alle anderen LEDs in der Spalte. Es sollte eigentlich dann eine einzige LED in
    der Spalte dunkel sein, die ist dann kaputt (zu heiss gelötet, Anschlüsse zu stark abgeknickt, ...). Gerade bei den billigen LEDs darf man da vorsichtig sein, da hat wohl jeder schon einige tauschen müssen
    der eine Matrix gebastelt hat, hatte ich auch ein paar.
    hey seddi ,
    ich versuch mal step by step .

    USB2Serial ist Installiert . Und richtig verbunden da ich eine kleine sehr hilfreiche Platine dazu bekommen habe .
    RXTX liegt im Glediator Ordner ..(32 Bit Version)
    Sorry .. ja es ist die Platine von Solderlab
    Die Settings sind so wie von dir beschrieben ..
    Nach Open Serial ... bleibt das Programm leider stehen ,läuft gaaaanz langsam .

    Ich werde mal die einzelnen Led Testen .. letzten hatte ich schon eine ausgetauscht

    Ich hoffe das sind ausreichende Infos ..
    Was für Fotos wären denn hilfreich ?

    mstevica schrieb:

    Ist Glediator mit "enttec open dmx usb interface" arbeiten?


    Nein. Glediator kann "nur" direkt seriell ausgeben oder über Netzwerk (Artnet,TPM, etc.). Ein DMX Interface kann nicht direkt angesteuert werden.

    @Pete
    Wenn das Programm nach dem öffnen "stehen" bleibt ist wohl die serielle Leitung "verstopft" ;) Sprich die Kommunikation mit der Steuerplatine funktioniert
    nicht. Also Kabel, Verbindung USB2/Serial -> Kabel, Kabel->Steuerplatine evtl. noch Stromversorgung für die Steuerplatine (PowerLED leuchtet auf der Platine?)
    oder ganz doof wäre eine geschrottete Steuerplatine.
    so ..

    Also ich hab ein neues Patchkabel gekauft .....
    Netzteil ist 5 V , 2500mA

    Leds hab ich geprüft ..keine def.

    Ist es richtig das die Grüne Debug Led Blinkt ?
    Diese Leuchtet aber erst nachdem ich den Atmega und die drei TLC ausgetauscht habe

    Der SN74HC138DRG4 IC2 ist ganz schön heiss !
    Und komischerweise Leuten zwei Leds obwohl nur die Plusreihen noch dran sind und alle anderen Stecker abgezogen habe.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Pete the Beat“ ()

    @Pete
    Hmm ... Als was die Debug LED genau anzeigt, müsste man mal Pepe fragen. Auf jedenfall hat die bei noch keiner meiner 4 Platinen geleuchtet, daher nehm ich das mal als ein schlechtes Zeichen bei dir.
    Platine nochmal überprüft ? Irgendwo vielleicht doch ein kurzschluss durch zu viel Lötzinn ? Irgendwas verpolt ? Poste doch mal ein paar Bilder der Platine.
    Atmega hat seine Software bekommen und alle Fuses sind gesetzt ?

    //EDIT
    Hab gerade mal in die Firmware reingeschaut, die Debug LED ist definiert, wird aber nirgends aktiv verwendet. Wenn diese bei dir blinkt läuft bei dir irgendwas richtig schief, sprich da ist wirklich
    was zu Tode gelötet oder die richtige Firmware sitzt nicht im Atmega.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Seddi“ ()

    Pete, ich würd dir ja wirklich gern helfen. Aber wie schon ein paar mal erwähnt, geht das nicht ohne Infos/Bilder.
    Klar, du benutzt die Plaitne von Solderlab, und wenn ich es richtig rauslese, hast du die nackte Platine bei AH bestellt sowie die bereits geflashten Atmegas und
    nicht die fertig bestückte SMD Variante, korrekt ? Das sind Infos die nicht uninteressant sind ;)

    Wenn du nur eine Patchbuchs und den HC138 gelötet hast, wer hat dann den Rest gelötet ? Sind ja ein paar Bauteile mehr. Klar, Atmega und TLC sockelt man
    normalerweise, also kannst du die kaum zu Tode löten, aber diverses anderes Zeug kann passieren (Pins zusammengelötet und was weiss ich). Ich will dir ja nicht
    annähernd unterstellen das du nicht löten kannst, sehe ja an deinen anderen Projekten das du mit dem Lötkolben durchaus umgehen kannst. Aber schnell passiert
    mal was und manchmal sieht man den Wald vor lauter Bäumen nicht mehr. Da sehen einige im Forum hier auf hochauflösenden Bildern vielleicht gleich den Fehler
    den du bisher übersehen hast. Wenn du Hilfe willst, dann versorg uns mit Informationen, dass man dir auch helfen kann.

    Fakt ist, so wie du es beschreibst, dass mit deine Steuerplatine irgendwas nicht stimmt bzw. defekt ist, kurzgeschlossen oder was auch immer, anders kann ich
    mir deine Fehlerbeschreibung beim besten Willen nicht erklären.

    Grüße
    Sven
    Hallo,
    Ich hab ein Problem mit der Ansteuerung meiner Matrix mit 20x30 rgb ws 2811 Pixel. Und zwar funktioniert soweit alles bis auf die Ausgabe auf artnet. Das erste Universum funktioniert, beim 2ten flackert die Ausgabe, bei 3und4 ruckelt es. Mit anderen dmx Programmen geht es alles. Wenn ich dann 2 verschiedene artnet interfaces benutze mit 2 unterschiedlichen ips, dann funktioniert immer nur 1 und nach ca 1 minute dann das andere und das 1te bleibt stehn. Das wechselt dann immer hin und her. Das 2te uni. Flackert dann auch immer.
    Hat jmd vielleicht ne Idee?
    System wurde mit win7 64Bit und mit WinXP getestet immer gleiches ergebniss.

    Alles Ok, Funktioniert wieder wie es Soll! Max Adressen beim Einstellen vom Artnet beachten und dann klappts auch. ! Wichtig ! Fängt bei 0 an zu zählen ! :D

    Projekte:
    abgeschlossen LED RGB Tubes

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Runner2k“ ()

    hey, ich habe eine frage an die programmierer!

    ich bin selber an basteln der wände und klappt alles soweit so gut, jetzt sollte noch die software einwenig optimiert werden.
    ich nutze ein altes/modifizierter genralüberholter kassenpc mit touchscreen. gibt es da die möglichkeit schieberegler und knöpfe größer zu machen, damit ich auch mit meinen wurstfinger auch alles treffe wenn es darauf ankommt.

    in der erprobung sind mir noch n paar weitere Features eingefallen, wie knöpfe / effekte / fenster per hotkeys ansprechbar machen und natürlich frei definierbar.

    ein knopf/switch für schwarzes bild (alles aus) und auch per knöpfe ein extra effekt oder vordefinierter kombi effekt, wie ein Audienz blinder zum zuschalten, für den perfekten moment ;)

    3D-Glediator?

    Over a year ago I wrote in this thread, that would be good to include support for 3D-matrix in Glediator. And now Madriks preparing to become a three-dimensional! And my dream would come true, but the price madriks makes me very sad ...



    I connected my DIY Universelle RGB LED Matrix Platine to my RGB-cube. Yes, the simple effects like Fade and scroll, work, but this is not enough to me ... I tried to capture Mardiks effects from screen and convert them to GIF, but it looks poorly ...



    So again, back to the issue of three-dimensionality:

    How difficult is it to make a 3D-Glediator?

    Why not do it? 3D-matrix - it's very beautiful!

    In fact, we need only a new set of 3D-effects, mapped on to the 2D-matrix, for example, 8x64 for a 8x8x8 cube




    Or am I so alone in this? ;)