Signalprobleme mit 74HCT244

    Signalprobleme mit 74HCT244

    Hallo LED-Gemeinde,

    ich hatte versucht, einen WS2812B-Stripe (5V) über einen Pegelwandler 74HCT244 von einem ATmega328P (3,3V) anzusteuern. Jetzt habe ich das Problem, dass am Ausgang des Pegelwandlers kein sauberes Signal rauskommt:



    gelb: Ausgang vom ATmega, saubere Flanken mit 3,3V-Pegel
    blau: Ausgang vom 74HCT244, keine sauberen Flanken, Pegel ca. 4,1V anstatt von 5V

    Schaltplan habe ich gerade nicht zur Hand. Aber vielleicht hat ja einer von euch eine Idee, worauf ich jetzt gerade einfach nicht komme...

    Viele Grüße.
    --ledjunke
    Abblockkondi ist schon dran am IC..?

    Seriendämpfung, also Widerstand mit 10-22 Ohm zwischen Ausgang und Stripe könnte auch helfen...
    It's only light - but we like it!

    Da es sich in letzter Zeit häuft: Ich beantworte keine PNs mit Fragen, die sich auch im Forum beantworten lassen!
    Insbesondere solche von Mitgliedern mit 0 Beiträgen, die dann meist auch noch Sachen fragen, die bereits im entsprechenden Thread beantwortet wurden.
    Ich bin keine private Bastler-Hotline, technische Tipps etc. sollen möglichst vielen Lesern im Forum helfen!
    Hier ist der Schaltplan:
    Kondensator ist drin.



    microcontroller.net/articles/Pegelwandler:
    3,3 V auf echte 5 V (CMOS) geht am einfachsten mit einem Baustein
    der HCT-Familie (NICHT HC!). Diese haben TTL-kompatible Eingänge und
    echte CMOS-Ausgänge


    Von dort habe ich die Idee, es so zu machen.

    Was mich stützig macht, sind zwei Dinge:
    • warum sieht das Signal so "komisch" aus
    • warum kommen keine 5V Pegel raus
    Habt Ihr noch ne Idee zu den "warum"s?
    Nun bin ich endlich dazu gekommen hier noch einmal die Gründe zu untersuchen...

    Falls es noch jemanden interessiert:

    Es war tatsächlich eine Induktivität. Ich hatte in der Tat übersehen, dass ich am Ausgang des 74HCT244 noch ein längeres Kabel dranhängen hatte (ohne angeschlossene LEDs). Manchmal sieht man den Wald vor lauter Bäumen nicht. Also Kabel gekürzt und alles ist gut.

    Irgendwie bin ich aber trotzdem überrascht, dass das Kabel alleine solche gravierenden Effekte auslösen kann...
    Ein zusätzlich am Ausgang angeschlossenes, längeres Kabel wirkt wie eine unterminierte (bzw. extrem hochohmig terminierte) 'Transmission Line'. Bei Flanken-Anstiegs- und Flanken-Abfall-Zeiten von wenigen ns (beim 74HCT244) bekommst du Signalreflektionen am unterminierten Kabelende, welche dann wieder zum Kabelanfang 'wandern' und dort dein Ursprungssignal überlagern. Das kann je nach Kabellänge und je nach Länge der Signal-Pulse diese mehr oder weniger stark (bzw. signifikant) beeinflussen. Ein Terminationswiderstand von ca. 1kOhm gegen Masse am Ende des Kabels hätte wahrscheinlich auch geholfen, aber das Kabel stark zu kürzen bzw. wegzulassen geht natürlich auch.

    Wenn du auch zur Verbindung mit dem Strip ein längeres Kabel verwendest, würde ich am Strip-Anfang (bzw. Ende des Verbindungskabels) auch einen 1 kOhm Widerstand gegen Masse schalten, denn der Eingang eines WS2812 ist auch sehr hochohmig (d.h. praktisch unterminiert).

    Gruss
    Neni
    Danke für die Erklärung... wieder was gelernt. Jetzt wird mir auch klar, warum man bei vielen Datenleitungen diese Abschlusswiderstände braucht ;)

    Kabel kürzen war hier jetzt kein Problem. Ich wusste nur anfangs noch nicht, wie lang es genau werden muss, daher hatte ich es nicht abgeschnitten. Den Widerstand spendiere ich aber jetzt trotzdem noch, damit auch garantiert nix mehr schief geht...