Der diskrete 1A LED Abwärtswandler

    Der diskrete 1A LED Abwärtswandler

    Glück Auf liebe LED Bastler,

    heut möchte ich eine Schaltung vorstellen, deren Idee ich schon ne Weile mit mir herumtrage. Gemeint ist ein stromgeregelter Abwärtswandler zum Betrieb von Leistungs-LEDs, der nur mir drei Transistoren und ein paar Bauelementen drumherum auskommt. Gestern hatte ich dazu (auf dem Klo, wo sonst :D ) den passenden Geistesblitz, wie sowas aufzubauen ist. Also heute Abend mal zusammengebaut, natürlich wieder als Drahtknäuel, geht wunderbar.

    EDIT: Leider sind die Fotos verschollen. Na egal, mehr als ne leuchtende LED sieht man eh nicht.

    Die Schaltung läuft bereits bei etwa 4-5V an und erlaubt den Betrieb auch bei noch weit höheren Spannungen. Testen konnt ichs bis 17V, auch dann hat die Stromregelung auf I=350mA noch gut hingehauen. Zudem wird der Leistungstransistor bei keinem Betriebszustand auch nur ansatzweise warm. Der Wirkungsgrad liegt bei gemessen 50-55% nicht so hoch wie erwartet, allerdings befürchte ich, daß mein Meßgerät aufgrund der Schalterei irgendwelchen Mist mißt. Warm wird, wie gesagt, nicht ein Bauteil, so daß er meiner Meinung nach höher anzusetzen ist. Aber selbst wenn nicht, ist das noch jeder Leistungsabbratmaschinerie überlegen.

    So sieht der Schaltplan des Prototyps aus:



    Das sollte doch für jeden Bastler auch ohne Erfahrung im Miniaturpfusch möglich sein. Zudem hat jeder die dafür benötigten Bauteile in der Wühlkiste rumliegen respektive man kann sie von einer alten Platine herunterbauen. Auf die Frage nach dem 2SB772, den hab ich nur grad rumliegen. Bei 350mA kann man auch noch nen BC327 nehmen, bei 1A LED Strom sollts dann schon ein BD140 oder noch was etwas dickeres sein. Alles andere sind Universaltypen. 2N3904, BC548, SC236, gehen alle. Die Größe der Induktivität ist hierbei Wurstegal, die Schaltung frißt alles, solange es nicht kleiner als 22µH wird. Wichtig ist allein die Strombelastbarkeit, die sollte bei der Spule ausreichend bemessen sein. Ein Faktor von 1,5 gegenüber dem mittleren Strom ist ein guter Anhaltspunkt, dann geht es gut.

    Eingestellt wird der Strom mit R6, so daß hier etwa U_R6=800mV Spannungsabfall entstehen. Je nach verwendetem Leistungstransistor kann die Schaltung auch mit sehr hohen Strömen bis jenseits 1A laufen, allerdings ist dann sicher ein Darlingontyp oder noch ein weiterer Transistor vonnöten. Zu beachten ist auch, daß der Strom, bedingt durch das Arbeitsprinzip der Schaltung des Prototyps, mit steigender Eingangsspannung geringfügig ansteigt. Das sind aber, wenn man von 5 auf 15V geht, nur ca. 30-40mA, sollt ner Leistungs-LED kein ernsthaftes Kopfzerbrechen bereiten.

    An den restlichen Widerständen sollt man nicht rumspielen, die sind für die korrekte Funktion des Schaltwandlers in der Form zwingend notwendig.

    Abschließend hat man mit der gezeigten Schaltung ein wunderbares Instrument, LEDs in Autos, Halogenanlagen oder was weiß ich wo unterzubringen, ohne nur leistungsvernichtende Stromquellen mit linearem Arbeitsprinzip zu verwenden. Zudem läßt sich die Schaltung auch gut miniaturisieren. Anwendungen fallen mir schon genug ein...

    Sooo, denn mal viel Spaß beim Nachbauen.

    PS.: PWM Dimming geht mit einem Transistor und einem Widerstand zusätzlich auch. Bedingt durch das Regelprinzip macht man dabei auch bei höheren Frequenzen die Regelung nicht wuschig.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Kurzschluß“ ()

    Hallo Kurzschluss,

    auch von mir Anerkennung, das Verhältnis Bauteilekosten
    zu Ergebnis ist nicht von schlechten Eltern :thumbup:

    Was mich auch hat stutzen lassen, ist deine ermittelte
    Effizienz von 50 - 55% zumal wenn nix warm wird ?(

    Hab mir dann mal überlegt, wer hier was verheizt:

    1. Hauptübeltäter ist natürlich R6 mit 0,8V * 0,35A = 0,28W
    Lässt sich aber in einer diskreten Schaltung kaum verkleinern,
    da hülfe nur der Einsatz eines OpAmps

    2. L1 kann ich nicht genügend beurteilen. Hier spielt der ohmsche
    Widerstand der Kupferwicklung mit rein. Vielleicht 0,3 Ohm
    ergibt 0,04W ohmscher Verlust. Wenn das Teil allerdings in die
    Sättigung gerät, erhöhen sich die Verluste noch um einiges.

    3. T1 hat sicherlich gut zu tun, ich denke mal 0,3V * 0,35A = 0,1W

    4. D1 halte ich für keine ideale Lösung; die ist zwar schnell hat aber
    rd. 0,7V Durchlassspannung ergibt 0,7V * 0,35A = 0,245W.
    Nun ist die aber nur zur Hälfte aktiv, wenn T1 gesperrt ist, also
    rechnen wir mal 0.12W Verlust. Hier würde ich besser eine Schottky
    Diode einsetzen, die nur ca. 0,4V Durchlass hat

    5. Die anderen Bauteile dürften weniger eine Rolle spielen. Eine Ersparnis
    sollte sich noch einstellen, wenn T3 einen Basis-Vorwiderstand erhält,
    wie Lötmeister vorgeschlagen hat.

    Dann fassen wir mal zusammen:
    1. 0,28W
    2. 0,04W
    3. 0,1W
    4. 0,12W
    5. 0,05W?
    Ergibt Summe 0,59W

    Die LED können wir als Nutzleistung mit 3,3V * 0,35A = 1,155W ansetzen
    Die Eingangsleistung ist also 1,155 + 0,59W = 1,745W
    Ergibt nach Dreisatz 66% Effizienz.

    Nunja, es sind einige Annahmen und Schätzungen dabei, aber ich denke mal,
    dass hier sichtbar wird, dass sich die Verluste 'zusammenläppern" und
    nicht so einfach zu beseitigen sind. Kann auch sein, dass ich mich mit
    meinen Annahmen 'verkalkuliert' habe. Da möge sich jedermann 'konstruktiv'
    äußern und zur Verbesserung beitragen :thumbup:
    Schöne Aufstellung, BerndK. So gesehen ist das theoretische Maximum des Wirkungsgrades bei einer LED gar nicht so weit weg von den gemessenen Werten. Vor allem fließt auch durch R2 und R4 permanent ein gemittelter Strom von rund 15-20mA bei 12V, der ebenfalls nicht bei der LED ankommt, sondern nur in der Schaltung an sich wirkt. Den kann man in die Rechnung durchaus mit einbeziehen.

    Des Weiteren hab ich das mit dem Basisvorwiderstand von T3 mal mit verschiedenen Werten getestet. Eine wirkliche Verbesserung des Wirkungsgrades bringts nicht. Bei 4,7k Basiswiderstand nimmt die Schaltung sogar 20mA mehr auf, als ohne. Wem es im Sinne der Transistorenschonung lieber ist, der kann bedenkenlos 470 Ohm oder sowas einbauen, es wird nichts schaden. Allerdings läuft die Schaltung auch ohne den Widerstand ziemlich gut. Vielleicht kann man hier auch noch etwas mit dem idealen Wert spielen, allerdings hab ich jetzt gerade keine Zeit mehr zum experimentieren.

    An sich haut es soweit hin, daß man die Schaltung mal in der Praxis im Dauerbetrieb testen könnte.
    Servus,

    und wieder mal geniales Drahtknäuel vom Kurzschluß, Super gemacht! :thumbsup: :thumbsup:
    Einfach und funktionierend, was will man mehr.

    Ich habe die Schaltung mal nachgebaut mit BD140 und 68µH bzw. 330µH Spule,
    funktionieren beide, irgendwas schwingt noch, kann aber auch mein Aufbau sein.
    Mit Basiswiderstand und 150pF vor dem Transistor gegen Masse.

    Meine Messwerte bei 12V Eingangsspannung kommen auf 61,5% Wirkungsgrad,
    es wird eigentlich nix mehr als Handwarm bei ca. 360mA LED Strom.

    Der Wechsel von einer BYV27 zu einer 1N5818 brachte nur ca. 1,5% mehr Wirkungsgrad,
    das möchte ich fast in der Kategorie Messfehler ablegen, so gering ist das.

    Evtl. könnte ein Wechsel zu einem P-Kanal Mosfet noch was bringen,
    mal schauen ob ich mal Lust habe, habe gerade wieder abgeräumt.

    Meine ebenfalls diskret aufgebauten KSQs mit OPV kommen auch nur auf höchstens 70%,
    von daher ist das für diese kleine Schaltung schon sehr ordentlich. :thumbup:


    MfG Raimund

    Lötmeister schrieb:


    Das hat auch niemand behauptet. Aber schaltungstechnisch gehört er schon hin, damit T3 nicht zu sehr in die Sättigung gefahren wird und auch als eine Art Schutzwiderstand.


    Hast schon recht. Werds bei Gelegenheit mal im Schaltplan im ersten Post noch einfügen.

    RH schrieb:

    Evtl. könnte ein Wechsel zu einem P-Kanal Mosfet noch was bringen,
    mal schauen ob ich mal Lust habe, habe gerade wieder abgeräumt.

    Meine ebenfalls diskret aufgebauten KSQs mit OPV kommen auch nur auf höchstens 70%,
    von daher ist das für diese kleine Schaltung schon sehr ordentlich.


    P Kanal Mosfet kam mir auch schon als Idee. Das sollte auch gehen, allerdings ist der Gateentladewiderstand R1 dann kleiner zu wählen, um das Gate schnell genug entladen zu können. Andernfalls sollte man noch einen Transistor ausgeben, um das Gate mit einer Push-Pull Stufe anzusteuern.

    Der Wirkungsgradvorteil der OPV Variante liegt sicher im kleineren Stromshunt oder täusche ich mich da?
    Servus,

    @ Lötmeister:
    Mit der 68µH Spule ca. 18kHz, mit 330µH ca. 7 kHz, hier war der Ausgangsstrom
    bei identischen Eingangswerten ca. 10mA höher, ist aber nicht besonders zu bewerten.

    Eine gekaufte KSQ zum Vergleich hat einen Wirkungsgrad von 80% bei 85 kHz.
    Allerdings auch ordentliche Spikes mit zahlreichen Oberwellen, hier hilft aber
    ein kleiner guter Elko und das Problem ist erledigt.
    Wenn die KSQ nicht über PWM gedimmt wird kann der Elko auch größer ausfallen,
    dann gibt es eine sehr geringe Restwelligkeit und saubere Gleichspannung.


    @ Kurzschluß:
    Du hast schon recht, bei einem MosFet wird es ohne Treiberstufe kaum gehen.

    Mit einem OPV kann der Shunt kleiner ausfallen, da reichen Spannungen von
    ca. 100mV bis 200mV, je geringer die auszuwertende Shuntspannung ist umso
    mehr Schwingneigung zeigen allerdings die Schaltungen.
    150 – 200mV ist aber eigentlich immer ein guter Wert gewesen.


    MfG Raimund
    Hab auch noch mal etwas an meiner Schaltung herumgemessen. Bei 22µH erreiche ich bei 5V (Anlaufen der Oszillation) etwas über 100kHz, was bis 15V auf über 400kHz ansteigt. Gemessen hab ichs mit der Frequenzmeßfunktion von meinem Multimeter.

    Die Werte erscheinen mir zwar ziemlich hoch, aber das Verhalten an sich stimmt schonmal, da der Stromanstieg an der Induktivität bei höherer Spannung größer ist. Exakten Aufschluß gewinnt man nur mit nem Oszi aber sowas hab ich zu Hause leider nicht rumstehen. Mal sehen, vielleicht geh ich der Sache auf Arbeit nochmal nach.

    Aber wenn die Frequenz wirklich so affenartig hoch ist, böte die Schaltung noch sicher einiges Potential zur Miniaturisierung. Sollte man mal schauen, ob sich irgendwo dicke PNP SMD Transis auftreiben lassen, die bis zu 4A bei geringen Vorwärtsspannungen schalten können. Dann kann man auch ne SSC P7 damit betreiben.

    @RH: Das mit der kleineren Shuntspannung mit OPV ist schon klar, nur ist das mit so einer Minimalvariante mit nur drei einfachen Transistoren nicht hinzubekommen. Dazu braucht man mindestens einen Differenzverstärker, das sind schonmal noch mindestens zwei Transistoren mehr. An der Stelle ist nichts zu machen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Kurzschluß“ ()

    Kurzschluß schrieb:

    etwas über 100kHz, was bis 15V auf über 400kHz ansteigt. Gemessen hab ichs mit der Frequenzmeßfunktion von meinem Multimeter.


    Das kenne ich, bei der 330µH Spule sagt mein Mutimeter 82kHz, der Oszi 7kHz, dem glaube ich . 8o
    Das Multimeter misst die ganzen kleinen Spikes mit. :cursing:

    MfG Raimund


    PS:
    Die Schaltung ist so schon OK, das mit dem shunt nicht mehr geht ist mir schon klar.

    Lötmeister schrieb:

    Wer HF misst, misst Mist ... :thumbsup:


    Wer viel mißt, mißt viel Mist... Genau so seh ich das auch. Ist mir schon klar, daß man da jeden kleinen Oberschwinger mitnimmt. Habs allerdings an der Basis von T1 gemessen, in der Hoffnung, da nicht so viel Klingelei mitzunehmen. Naja der Oszi wird mir die Wahrheit offenbaren :D

    Ehrlich gesagt hätte ich die Frequenz zwischen 50 und 100kHz erwartet. Na wir werden sehen.
    *Fred wieder rauskram* :D

    Hallo an Alle.

    Ich löte mir gerade den diskreten Abwärtswandler zusammen. Nun hab ich eine Frage zu R2. Er ist angegeben mit 1k, nur genau den habe vergessen zu kaufen und er ist auch nicht in meinem Fundus ;( . 1,4k hätte ich aber zur Verfügung. Lässt sich dieser Widerstand auch verbauen oder soll ich doch lieber einen mit 1k verwenden?

    Grüße
    Alex

    EDIT: Die Schaltung funzt auch mit 1,4k bei R2 :D . Super einfach aufzubauen und sie hat auch gleich auf das erste mal funktioniert. Es wird auch wirklich nichts mehr als hanswarm. Ausprobiert wurde die Schaltung an 4 AA-Zellen ohne Probleme. Dann wollte ich sie auch mal an mehr Spannung testen und hing sie an einen kleinen 12V Bleigelakku. Nur ist mir dann leider binnen Sekunden R6 in Rauch aufgegangen :huh: . Ich bau sie mir nochmal auf, aber dann sauber und viel platzsparender. Das sieht jetzt recht wüst aus. R2 wird dann auch 1k wie vorgesehen.
    8| Wissen ist Macht, nichts wissen macht auch nichts. :D

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Sanguinius“ ()

    Wenn der R6 bei 4 AA-Zellen, also bei 4,8V oder 6V, nicht abgebrannt ist, dann bei 12V aber innerhalb von Sekunden, dann funktioniert dein Aufbau nicht. Möglich ist auch, dass R6 falsch dimensioniert ist und die Spannung der AA-Zellen so niedrig war, dass einfach nicht genug Strom fließen konnte. Bei 12V dann aber schon. Dabei müsste sich in jedem Fall auch die Helligkeit der LED stark erhöht haben.

    Der Strom durch R6 ändert sich bei korrekt funktionierender Schaltung mit der Betriebsspannung nur sehr wenig. Das ist ja grad der Sinn der Regelung.
    Jetzt hab ich die Schaltung nochmal aufgebaut, genau wie beschrieben. Es besteht aber immer noch das Problem wenn ich die Eingangsspannung erhöhe, erhöht sich recht stark der Strom . Bei 5,6V liegen rund 220mA an, bei 12,5V rund 360mA. Ich bin die Schaltung jetzt mehrmals durchgegangen, kann aber keinen Fehler finden :S .

    Grüße
    Alex
    8| Wissen ist Macht, nichts wissen macht auch nichts. :D
    Also 360mA bei einer LED an 12V würde ich jetzt mal als normal einstufen, da sollte auch nichts rauchen. Daß der Strom bei geringerer Spannung kleiner ist, ist normal, da ja erstmal der Spannungsabfall an R2 (rund 0,7V) und das U_CE_sat vom Transistor überwunden werden müssen. Da gehts erst bei 5V so richtig los.

    Gleichzeitig ist auch noch ein leichter Stromanstieg von ein paar % mit steigender Spannung vorhanden, was durch die Hysterese zustandekommt. Steht aber im ersten Post drin.
    Hallo, ich bin es nochmal.

    Also die Schaltung funktioniert nun einwandfrei. Der Strom an den LED's ist jetzt auch konstant mir nur wenigen mA Abweichung wenn die Spannung merklich sinkt. Betrieben wird die KSQ an zehn AA Zellen mit drei Cree XP-G R5 in Serie. T1 ist ein DB 140, L1 hat 33µH und R6 habe ich zwei mal. Einer mit 5,6 Ohm für ca. 130mA an den LED's, einen mit 1,3 Ohm wo dann 640mA durch die LED's fließen. Jetzt habe ich noch ein kleines Problem, wenn ich die Schaltung mit 1,3 Ohm an R6 betriebe wird T1 nach ca. 10 Sekunden so heiß das man ihn nicht allzu lange anfassen kann. Mit 5,6 Ohm an R6 bleibt T1 kalt. Was könnte sich für ein Fehler in meiner Schaltung versteckt haben ;( ? Zu klein dimensioniert? Eigentlich ja nicht, laut Datenblatt kann er bis zu 1,5A.

    Grüße
    Alex
    8| Wissen ist Macht, nichts wissen macht auch nichts. :D