Universelle Umsetzer-Platine - USB_Ethernet_SPI_Uart_DMX_Artnet

  • Hallo Toeb,


    sorry das ich Deinen letzten Post nicht beantwortet hatte. War bei mir in letzter Zeit etwas stressig durch Hausbau und Umzug. Aber nun ist es endlich geschafft :-)


    Nun die Stromaufnahme des UIB hängt ein wenig davon ab was genau Du damit machst. Beim reinen Datentransfer kannst mal Deine 12V drauf geben und das Teil 10 Minuten laufen lassen. Dann mal den 7805 Spannungsregler (das liegenden Bauteil neben dem Hohlstecker auf der Platine) anfassen. Wenn der nicht so heiß ist dass Du die Finger verbrennst ist alles fein :-) Hatte das UIB auch schon mal 'nen ganzen Tag mit 12V betrieben.


    LG,


    Pepe

  • Die Umsetzerplatine hat einen eigenen Spannungsregler auf 5V. 3Volt mehr solltest du anlegen, damit der Spannungsregler ordentlich funktioniert.
    Das Netzteil welches du ausgewählt hast ist meiner Meinung überdimensioniert (vom Strom).
    Ein Steckernetzteil 1A reicht locker zu. Wenn direkt an die Leitungen gehen willst mach sich ein Steckernetzteil eher schlecht.
    Sollte für deine Zwecke auch ausreichen: http://www.reichelt.de/SNT-RS-…137081&artnr=SNT+RS+15+12

  • Hi Leute.


    Bin ganz neu hier, also erstmal was ich gerade so mache:


    Ich habe basierend auf 4 Matrix Controller Boards und einem UIB eine 512 RGB-LED Matrix gebaut.
    Bilder kann ich demnächst mal posten.
    Läuft soweit ganz prächtig im GL-stand-alone Modus und als live-player per Gladiator.


    Nun habe ich mir ein RN-XV zugelegt und wollte das ganze auf die WLAN-Ebene heben.
    Das RN-XV hängt auch schon wunderbar in meinem WLAN aber mit der Datenübertragung klappts halt nicht.
    Ich auch logisch, wie ich festgestellt habe, da die Funktion in der UIB-Firmware scheinbar noch gar nicht implementiert ist.
    Das is jetzt nicht so wild; muss ich halt selber fertig proggen.
    ABER, mir ist was beim Hardware-Anschluss nich ganz klar.


    Das RN-XV läuft mit 3.3V und im Datasheet steht für den Rx auch nur "3.3V tolerant". Die Rx und Tx Leitungen sind aber direkt mit dem ATMega1284P verbunden.
    Also eigentlich 3.3V mit 5V Ports. Oder hab ich da nen Denkfehler?
    Ich würde mir jetzt ne Umsetzerplatine basteln; halte ich für das sauberste.
    Btw der Pin9 des RN-XV Anschlusses auf dem UIB liegt permanent auf 5V.
    Mag ja für DMX irgendwie nötig sein, is aber für das RN-XV, bei direktem Aufstecken, auch nich richtig gut.
    Es sei denn man baut eben ne Umsetzerplatine, dann isses ja sogar nötig die 5V zu haben.


    Noch ne Frage:
    Auf der Solderlab-Seite wird gesagt, der ATMega1284P hätte 256 kB internen Flash.
    Aber laut Atmel hat der nur 128kB, was die Produktbezeichnung auch vermuten lässt.
    Is das n Fehler auf der Solderlab Seite?
    Wenn ja, würde es die Erweiterung des Funktionsumfangs des UIB echt schwer machen.
    Komischerweise hat das hex-File der UIB Firmware auch bereits 138 kB. ???!!!


    Wär super wenn hier noch jemand zuhört und dazu was sagen kann.


    Gruß,
    c82

    The most exciting phrase to hear in science,
    the one that heralds new discoveries,
    is not "Heureka" (I found it) but
    "Well, that's funny".
    - Isaac Asimov

  • Hallo,


    der ATmega1284 hat in der Tat nur 128 kb FLASH. Der 2560, der auf dem Arduino Mega verbaut ist, hat 256 kb FLASH.
    Nun zur Größe des Hex-Files. Lies mal, was Wikipedia zum Hex Format sagt: http://de.wikipedia.org/wiki/Intel_HEX
    Da wird die Datenstruktur beschrieben und das das Hex-File in etwa doppelt so groß ist, wie die binären Rohdaten darin ;)
    Was bedeutet, das du immernoch genug Platz hast.


    Gruß Gerald

  • Hallo,


    ich bin am verzweifeln und bekomme kein Rat.


    Und zwar habe ich das Universal Interface Board und das Matrix Controller Board von Solderlab gekauft und bestückt. Zudem habe ich noch das Arduino USB2Serial erworben. Nach dem ganzen Aufbau leuchten die LEDs prächtig durch das Beispielprogramm, was wohl schon drauf war. Jetzt möchte ich natürlich selber Programme für meine 16*8 RGB Matrix über Glediator programmieren, bekomme jedoch leider keine Verbindung zum Board. Per LAN oder USB, beides geht nicht. Habe RXTX nach Anleitung eingebunden und mir wird auch der COM3 angezeigt, mit dem ich mich verbinden kann, jedoch wird als weiter das Beispielprogramm ausgeführt. Was mach ich noch falsch? ;(