Suche alte FotoHandys

  • So, kommando zurück, Digicam ist noch nicht defekt [-X
    Die Cam hat vor der Linse einen schiebeverschluss gehabt, welcher zwei kleine Metall-bänder als Schalter verbunden hat, um die Cam anzuschalten.


    Solange ich gebastelt habe, hab ich die Bänder durch eine Schraube verbunden.


    NEIN, nicht die Schraube hat gefählt, sondern das Kabel dieses Schalters hat sich unmerklich an der Lötstelle gelöst.


    Hab es wieder dran gelötet, geht wieder... ich melde mich wieder, sobald ich neue Probleme hab, eure Anregungen brauch, oder mein Projekt fertig ist.

  • Mh, da hab ich jetzt das nächste Problem. Unter der Linse ist der Bildsensor-Chip. Der ist allerdings anders als erwartet direkt auf die Platine gelötet.


    Die Platine ist von beiden Seiten bestückt. Mit meinen Apparaturen wird es woh demnach nicht möglich sein - wenn das überhaupt mit anderen gehen sollte - diesen zu entlöten, und flexibel per Kabelverlängerung einzusetzen.


    Alternative bleibt nur, das LCD-Flachbandkabel und die Stromversorgung des LCD-Displays zu verlängern.


    Großer Nachteil... dort wo die Linse hinkommt, muss die klobige Platine mit :-(


    Sind auf Hadys mit Fotofunktion die Sensoren auch direkt auf die Platine gelötet, oder sind die auf eines kleine separate Platine? Hat da jemand erfahrungen mit?

  • Nebenbei noch eine andere Frage. In der Digikam ist eine Platine mit Buttons (siehe Bild, die gelben knöpfe)


    Der button oben und rechts von dem oberen Kreuz funktioniert nicht mehr.


    Weiß jemand, wo da der Fehler liegen kann? Also ich meine, wenn die Lebzeit solcher Buttons überschritten ist, wie äussert sich das?


    Kann man einen solchen Button austauschen?

  • OK, ich löse das Ganze hier mal etwas auf...
    Sowohl Kamera als auch Display in einem Handy werden über Schnittstellen wie I2C oder SPI mit dem zentralen Prozessor des Handys verbunden.
    Diese Schnittstellen kann man super mit einem AVR bedienen (hey, dafür sind µCs da) - man braucht allerdings mehr als zwei Kabel und den Befehl SHOW_PICTURE_ON_SCREEN.
    Das wichtigste ist wie immer die Dokumentation: Ohne Infos zu dem Cam-Modul wirst du nie rausfinden, wozu welches der 64 Beinchen dient. Vergiss es einfach - sowas können echte Cracks, aber wir nicht. Alleine der Logic-Analyzer ist sauteuer.


    Und selbst mit Dokumentation ist es alles andere als einfach, vor allem wenn man Anfänger ist.


    Die Datenblätter sind übrigens grad bei den Cam-Modulen schwer zu finden - bei den Displays sind zumindest in der Community Infos zu bekommen.


    Aber ich habe auch gute Nachrichten: Wie fast alles wurde auch deine Idee schonmal von jemandem mit richtig Ahnung umgesetzt... schau mal hier rein ;-) http://www.ulrichradig.de/home…amera-furs-eth_m32-644_ex
    Das Protokoll wird auch etwas beleuchtet: http://www.ulrichradig.de/home/index.php/projekte/uC-kamera


    Für um die 50 EUR haste dann einen Webserver mit Cam und noch viel mehr! Und selbst bei dieser "Fertiglösung" wirst du noch schwer grübeln müssen!


    Die Cam und Platinen zum Server gibts im Shop, die Preise sind mal echt human!


    Dank der Doku sollte es sogar möglich sein, die Cam in Bascom anzusprechen - wobei man dummerweise ein JPG zurückbekommet - das müsste man dann erst mal interpretieren! (schon mal einen JPG Decoder geschrieben?) Dann kann man es umrechnen und skalieren und DANN an ein Display schicken.


    Viel Spaß!

  • Ok. ich glaub ich gebe mich geschlagen. Zumindest was den Umbau der Kamera angeht.


    Aber die Reparatur sollte doch möglich sein.
    Also was sagt Ihr, die beiden Taster, die defekt sind, kann man die austauschen? Wo liegt da bei wenn die Verschleißgrenze überschritten wird bei dieser art Schalter ( ist so ein metalldrucknopf) das Problem?


    Würde zumindest gerne die beiden Knöpfe wieder in Betrieb nehmen, damit die CAM richtig funzt.

  • Ich glaube nicht, dass es an den Knöpfen selber liegt.
    Kannst es ja mal testen, indem du die manuell per Draht überbrückst.
    Oder noch besser: mit dem Durchgangstester vom Multimeter die Taster überprüfen.


    Die Bauform der Teile ist auch nicht gerade Standart... Das wird ne miese Sucherei. Wie groß sind die denn genau?

  • Zitat von "rethus"

    Sind die 4 Lötstellen an den Ecken nciht lediglich um den Schalter fest zu justieren?


    Sicherlich.. und gehalten wird der Taster eigentlich von einer M15 mit Torx-Kopf und Flügelmutter... :-%


    Aber an sich sind die Lötstellen die Kontakte, ja.
    Multimeter dranklemmen und Widerstand an/aus testen?

  • Die oberen und unteren Kontakte sind unterbrochen und werden durch einen Tastendruck verbunden.


    Demnach scheinen die beiden Schalter noch OK zu sein.
    Mh, dann liegt die gaze sache bestimmt wo anders im argen.


    Was mich nur wundert, das es lediglich die Buttons für rauf und rechts sind, die nicht funktionieren.
    Weiß jemand woran es noch liegen könnte?