Beiträge von BerndK

    Es geht noch besser:
    https://www.ebay.de/sch/i.html…ku+18650+9900mah&_sacat=0


    147 Angebote für 18650 LiIon Akkus mit 9900 mAh. Sind wahrscheinlich in echt eher 990 mAh.
    Komisch, mehr als 9900 mAh anzubieten, traut sich keiner. Ist wohl ein Gauner-Agreement :D
    Und richtig, wer deutlich mehr als 3500 mAh angibt, ist ein Angeber :thumbup:


    Hier mal eine Adresse für echte und günstige 18650er Akkus von Markenherstellern:
    https://www.nkon.nl/rechargeable/18650-size.html


    Darauf gekommen bin ich durch einen Thread, wo sich jemand einen 5 kWh LiIon Akkus aus den Zellen baut:
    https://www.photovoltaikforum.…-5kwh-nutzba-t114773.html


    Auf Seite 4 wird dann der Lieferant genannt; nämlich nkon.nl

    Nächster Erklärungsversuch:


    Es handelt sich um ein Bauteil der Fa. Vishay (Doppelbrezel unten). Hierzu das Diodesgroupbodymarking:
    http://www.vishay.com/docs/88912/diodesgroupbodymarking.pdf
    Dort findet man auf Seite 3 unten, dass 'ED' der Typecode ist und '33' das Herstellungsdatum; also März 2013.


    In einem weiteren pdf findet sich was zum 'ED':
    http://www.vishay.com/doc?88579
    Und gemäß Device Marking Code ist es einen Ultrafast Diode 200V 1A.


    Und das ganze ohne Gewähr 8)

    Zufällig habe ich am vergangenden Wochenende mit einem Arduino angefangen.
    Mich hat ein kompatibles Bord für 9,99 EUR angelockt, das ich dann bestellt habe:


    https://www.amazon.de/gp/produ…age_o03_s00?ie=UTF8&psc=1
    Wie ich gerade sehe, ist das momentan nicht lieferbar. Spielt aber keine Rolle, das Original gibt es ja auch.
    Jedenfalls ist ein USB Kabel dabei, welches die Verbindung zum PC herstellt.


    Der nächste Schritt war die Installation der ARDUINO IDE 1.8.1 als Windows Installer. (Nahezu Freeware)
    OK, hat 3 EUR über Paypal gekostet, aber es war eine gute Investition.


    Damit wurde der Arduino erkannt und ich konnte sofort die Beispiel-Sketche
    (so nennt man dort die Programmierungs-Beispiele) ausprobieren und die funktionierten sofort.


    Wenn dann alles funktioniert, kann man das Teil abnabeln und über Rundstecker versorgen.

    Ein weiterer wichtiger Parameter, auf den man beim MOSFET achten sollte, ist die Total Gate Charge, abgekürzt Qg
    Je niedriger der Wert ist, desto schneller wird das Gate umgeladen und somit wird Verlustleistung im Umschaltmoment vermieden.
    Das ist besonders wichtig, wenn der MOSFET von einem Microcontroller direkt ohne Treiber mit PWM betrieben werden soll.


    Leider haben MOSFETs mit niedrigem Qg meist einen hohen RDSon und umgekehrt, was herstellungsbedingt voneinander abhängt.
    Hier muss man entsprechend Kompromisse eingehen und die Wahl nach den eigenen Anforderungen treffen.


    Ein geeigneter MOSFET gemäß den Anforderungen des TO könnte auch dieser sein:
    http://www.tme.eu/de/Document/…8f0c01a07/irlb8721pbf.pdf


    - Uds mit 30V ist erfüllt.
    - Ids mit 10A passt locker. Die Verlustleistung ist mit I² x Rdson = 100 x 0,013 Ohm (bei 4,5V Ugs) = 1,3 Watt und somit ohne Kühlung zu bewältigen.
    - Qg ist hierbei mit 7,6nC spezifiziert und somit bestens geeignet zur Ansteuerung direkt vom Mikrocontroller.

    Ich habe mir vor einiger Zeit ein Bosch Gerät zugelegt, das GMS 120.
    Ist schon recht gut, aber auch nicht perfekt. Man muss lernen, die Ergebnisse zu interpretieren.


    Mitunter wird 'Strom' angezeigt, auch wenn da nichts ist. Vermutlich, wenn die Wände
    Restfeuchtigkeiten enthalten und geringe Streuströme vorhanden sind.


    Wenn eine stromführende Leitung nicht angezeigt wird, hilft es oftmals, wenn ein Verbraucher
    eingeschaltet wird, damit Strom fließt.


    Wenn ich ein Loch bohren will und mir nicht ganz sicher bin: Mit einem alten Schraubenzieher den
    Putz vorsichtig aufprocklen und visuell kontrollieren, dass da keine Leitung ist. Ist am sichersten.


    Falls sich jemand für das GMS 120 interessiert, hier ein Video:

    Kann diese mit 3A arbeiten? Wenn ich das richtig überschlagen habe sind das 300Ohm für R1 ? .
    Und Leider weiß ich nicht mehr und kann aus den Bauteilen auch nicht Lesen ob das PWM Signal hier funktionieren würde.
    Kommt diese KSQ mit dem Relativ hohem Spannungsunterschied zurecht? Oder muss ich doch 2 Verbraucher in Reihe setzen und somit 6,1V verbauchen?


    3A sollte kein Problem sein. Der IRF5305 möchte ein wenig gekühlt werden und Drossel und D4 müssen den Strom abkönnen.


    300 Ohm für R1 ist völlig daneben. Die Formel lautet I = Vref / R1. Im Schaltbild ist R1=0R5 das ergibt 0,1 / 0,5 = 0,2A
    Um den Widerstand R1 zu bestimmen, dreht man die Formel einfach um: R1 = Vref / I und man erhält 0,1 / 3 = 0,03333 Ohm also rund 33 Milliohm.


    Für D2 eine Z-Diode zu nehmen, ist daneben. Bei Spannungen um 3V ist die Spannungskonstanz einer Z-Diode recht schlecht.
    Da nimmt man besser eine Bandgap-Referenz wie TL431 oder LM385-Z2.5 und passt R6 und R7 etwas an.


    Eine positive Spannung am PWM Anschluss wird die Bestromung der LED unterbrechen. Ist also invertiert, darauf sollte man achten.


    Mit der PWM-Frequenz muss man allerdings etwas aufpassen, dass die nicht zu hoch wird und in die Nähe der Schaltfrequenz des Reglers kommt.
    Ein paar 100 Hz sollten für die PWM ok sein.


    Gruß
    Bernd

    Dass eine Unterbestromung die Farbwiedergabe beeinflusst, ist mir bekannt.
    Aber dass sich die Lebensdauer dadurch negativ auswirkt? Halte ich für sehr unwahrscheinlich.


    Eine Heatpipe ist in der Tat eine elegante Möglichkeit, die Wärme von der Quelle (LED) weg zu transportieren.
    Aber letztlich muss die Wärme am anderen Ende der Heatpipe irgendwo abgeführt werden.
    Und das muss dann irgend eine Temperatursenke sein; etwa ein Kühlkörper oder was auch immer.

    Es gibt durchaus eine Möglicheit, eine High Power LED ohne zusätzliche Kühlung zu betreiben. Stichwort: Unterbestromung.
    Wenn man eine LED mit besonders hoher Effizienz nimmt, wird überproportional viel Leistung in Lumen umgesetzt, statt in Wärme.


    Ich habe mal eine XP-L V6 auf Starplatine hier aus dem Shop diesbezüglich ausgemessen.
    Bei einer Bestromung von 300 mA (ohne zusätzliche Kühlung) erreicht die Temperatur am Star 32°C und steigt nicht weiter.
    Hier kann man durchaus noch etwas mehr herausholen, je nachdem welche Temperatur man als zulässig erachtet.


    Die hierbei relevanten Parameter kann man aus folgendem Beitrag entnehmen (Tabelle weiter unten):
    http://budgetlightforum.com/node/31630?page=2


    Die Effizienz beträgt hierbei 200 Lm/W
    Der Lichtstrom beträgt rd. 171 Lm


    Ja, ich weiß, das ist, wie wenn man sich einen Porsche kauft und nur 30 km/h damit fährt.
    Aber wenn man absolut keinen Kühlkörper haben will, wie z.B. für eine Kopflampe mit Flutlichteffekt (bei mehreren LEDs),
    ist das doch schon eine Überlegung wert.


    Außerdem:
    nimmt man die genannte 0,5W LED mit ihren 19 Lumen, braucht man genau 9 Stück, um die 171 Lumen der unterbestromten XP-L V6 zu erreichen.
    Und bei 9 Stück ist der Preis dann fast doppelt so hoch.


    Gruß
    Bernd

    Die Anforderung 'möglichst leicht' ist hierbei nicht leicht zu erfüllen.
    Weil: High Power LEDs brauchen stets einen Kühlkörper, um die Wärme abzuführen.
    Und das geht immer gut ins Gewicht.


    Es gibt aber einen legalen Trick, um das zu umgehen: Unterbestromung.
    Bei deinem Ansatz ist eine XM-L2 U2 mit 525 lm bei 1400mA vorgesehen.


    Jetzt nehmen wir mal 3 Stck XM-L2 U4 auf Star aus dem Shop, schalten diese in Reihe
    und bestromen diese mit 400mA. Ergibt rd. 3x 200 lm = 600 lm. Schon mal sehr gut.


    Nachteil: Der Preis ist dreimal so hoch.


    Vorteile:
    - Es ist kein zusätzlicher Kühlkörper erforderlich. Bei meiner Messung bei 0,4A steigt die Temp. am Star nicht über 33°C.
    - Das Gewicht der 3 LEDs auf Star beträgt nur 3 x 1 Gramm (nunja, die Optik kommt noch hinzu)
    - Die Effizienz steigt durch die Unterbestromung auf 190 lm/W. Gut für den Akku.
    - Die Brennspannung pro LED liegt bei ca. 2,7V und damit passend zum Entladeschluss eines LiIon Akkus.
    - Durch 3 LEDs, wenn gespreizt angeordnet, können Schatten reduziert werden.


    Gruß
    Bernd

    Diskrepanz von Ausskies 50-100mV an R3 zu 150mV bei mir.


    Das liegt am Ohmschen Gesetz. Wenn du einen Widerstand von ca. 0,32 Ohm hast (3x1 Ohm parallel), wird die Spannung 0,477A * 0,32Ohm = 0,152V betragen.


    Nun zum Gesamtdrop von 0,53V. Das ist in der Tat die Differenz von Uin(Eingangsspannung) zu Uout (Brennspannung).
    Erwartest du nun bei Uin=12,3V minus Drop=0,15V ein Uout=12,15V? Nicht wirklich! Damit würde die LED mit 0,8A befeuert. Das ist nicht Sinn und Zweck.
    Nein, die Schaltung macht genau was sie soll: Sie liefert an die LED eine Spannung von 11,7 um den gewünschten Strom von 0,477A bereit zu stellen.
    Und das geht nur, indem ein Drop von 0,53V erzeugt wird; einmal an 0,152V an R3 + 0,378V am 'leicht leitenden MOSFET'. Alles richtig.


    Jetzt die Betrachtung bei Uin=11,8V. Der Strom ist 0,38A. Die Brennspannung der LED ist 11,63V (Aus Tabelle). Der Drop ist somit 0,17V. Na also, geht doch!


    Jetzt zu deinem Problem. Du erwartest natürlich, dass bei Uin=11,92V (11,77V + 0,15V) bereits die vollen 0,477 A rauskommen. Statt dessen sind es nur 0,43A. Immerhin.
    Das ist in der Tat die Schaltung, die das nicht besser kann, da hier mit Standard-Halbleitern eine trickreiche Regelung aufgebaut wurde bei begrenzter Verstärkung.


    Wenn es 'knackiger' geregelgt werden soll, hilft die OpAmp Schaltung, die auch erwähnt wurde.


    Gruß
    Bernd

    Da hast du etwas übersehen.


    In Akkuschraubern sind grundsätzlich hochstromfähige Zellen eingebaut; ob NiCd oder NiMH oder Lithium.


    Der Grund: Diese Motoren haben nicht nur einen hohen Anlaufstrom, sondern ziehen bei kräftiger Belastung,
    also kurz vor dem Blockieren gern mal um die 30A aus dem Akku. Und dafür muss der Akku ausgelegt sein.


    Damit ist der Buck-Konverter schon mal aus dem Rennen. Der kann das nicht. Ist aber auch unnötig.
    Ebenso scheiden geschützte Zellen aus, die würden nämlich einen Kurzschluss detektieren und abschalten.


    Und die 'normalen' ungeschützen Zellen, wie aus dem ebay Angebot, sind nur bis ca. 5A ausgelegt.
    Meine Empfehlung: https://www.akkuteile.de/samsu…5r-2500mah-3-7v/a-100657/
    Da gibt es schon bei 4S1P genügend Strom nämlich 20A Dauer und 100A Spitze. Und bei 4S2P richtig Power.


    Und die Spannung? Gegenüber einem vollgeladenen NiMh 12V hat ein 4S Lithium etwa 15-20% mehr Spannung.
    Da lacht der Motor und freut sich über das 'Mehr' an Power. Die sind nämlich sehr robust. Es gibt im Netz
    Berichte über Umbauer, die einen 12V Akkuschrauber mit 18V betreiben und sich über die Power freuen.


    Und die Ladeschaltung? Wenn die 4 Lademodule die fest verdrahtete Reihenschaltung der 4 Zellen laden
    sollen, geht das nur, wenn die Module von 4 Netzteilen gespeist werden. Wegen der Potentialtrennung.
    Wird die Reihenschaltung der 4 Zellen getrennt, genügt natürlich eine einzige 5V Speisung.

    Sehr schönes Projekt.
    Bezüglich LED gibt es aber noch Verbesserungsmöglichkeiten.
    Was im Shop nämlich nicht ersichtlich ist:
    Die angegebenen Werte der XM-L beziehen sich auf eine Chip-Temperatur von 25°C
    während z.B. die Werte der XM-L2 und XP-L für 85°C angegeben sind.
    Das ist schon ein erheblicher Unterschied, den man in folgender Tabelle sehen kann:



    Es handelt sich übrigens um ein Tool von Cree http://pct.cree.com/dt/index.html
    Da spricht doch einiges für die XM-L2 oder noch besser die XP-L


    Gruß
    Bernd

    Der Signalverlauf ist schon merkwürdig.
    Das lässt eine Induktivität vom Ausgang nach GND vermuten,
    die dann beim Abschalten diese negative Spitze erzeugt.
    Und auch entsprechend Strom zieht, dass die 5V auf 4,1V einbrechen.
    Ergo: Das Teil einfach entfernen ;-)