Beiträge von dottoreD

    dottore


    ach so, ich hab also "nicht verstanden, dass LEDs mit Konstantstrom betrieben werden". Aus welchem Teil meines Beitrags bist du denn zu dieser glorreichen Erkenntnis gekommen? Mal von der "Allgemeingültigkeit" der Aussage ganz abgesehen? Vielleicht weil ich dich berichtigt habe, dass es sehr wohl 48V Boards und keine 54 Volt sind?

    Weil es sehr wohl keine 48V boards sind. Welche Motivation hast du eigentlich zu fragen, wo du alles (besser) weißt? Aber lass gut sein.

    Weil du bisher nicht verstanden hast, dass LEDs nicht an Konstantspannung, sondern Konstantstrom betrieben werden. Und ja, das Netzteil war als Beispiel für 1 Board OHNE Kühler zu verstehen.


    Das kann man allerdings relativ leicht hochskalieren:

    4 boards in Reihe geschaltet, weil ich ohne weiteres nicht darauf vertrauen würde, dass der UF der boards ausreichend gleich ist:

    ergo 1,6A Strom, bei ~200V Ausgangsspannung


    Dann nehme ich aus der Meanwell-Reihe halt das HLG-320H-C1400, das hat bei 40% load leider auch bloß 90% Effizienz   ;). Und unterscheidet sich im Preis kaum von der Summe der Einzelnetzteile. Ebenso wie 2x HLG-185H-C1400.

    Etwas besser passen würde zwar eines mit 1750mA, das schafft aber aus der 320W Klasse die 200V nicht mehr, das wäre dann das HLG-480H-C1750, zum entsprechend höheren Preis.


    BTW, die Effizienz des Gesamtsystems wird nur zum geringen Maße von der Effizienz des Treibers definiert.

    Du brauchst definitiv kein 48V Netzteil.

    Ich kenne die Spec deines boards jetzt nicht, aber im Netz findet man für QB288 V2 Rspec® Quantum Boards:

    Max current per board 3000mA @ 54VDC

    Requires an Aluminum plate or heatsink if running 55+ watts or over 1050mA


    Also solltest du zuerst mal wissen mit wieviel Leistung jedes board tatsächlich laufen soll. Mit oder ohne Kühler. Daraus ergibt sich dann der Strom für dein Netzteil. Dieses wird dann ein KonstantSTROMnetzteil sein, mit entsprechender Leistung. Final ist zu schauen, dass der Spannungsbereich die ~54V einschließt.

    Für 1050mA wäre das zB ein pcd-60-1050

    Meiner Meinung nach reicht das zwischenschalten eines simplen Drehzahlstellers wie der hier Beispiel. Wenn man die richtige Helligkeit gefunden hat, kann man den Poti durch einen Festwiderstand ersetzen. Der reduziert den effektiven Strom durch PWM und funktioniert auch bei LEDs genauso gut, auch wenn das nicht angegeben ist.

    Alternativ kann man natürlich einen Streifen mit weniger Lumen einbauen.

    Nach meiner Ansicht: wenn immer möglich 2 in Serie, spart die Dioden, und bei 5A werden die gerne warm. Und das funktioniert eigentlich immer, auch bei ganz unerschiedlichen Strombegrenzungen


    zu Beachten: nicht zu 100% auslasten und dran denken, dass es denen unter der Decke nicht zu warm wird. Aber das gilt für alle.

    Erst dachte ich an ein elektrisches Problem, ist aber Klammersetzung {}. Bei einem Befehl direkt am "if" geht es, sobald was dazu kommt nicht mehr. Deshalb lieber immer so machen.


    Ist-Zustand:

    Code
    1. if (helligkeit == 30)
    2. delay (30000);
    3. }


    Soll:

    Code
    1. if (helligkeit == 30){
    2. delay (30000);
    3. }

    Bitte formatiere den Code auch immer mit den Code-Tags, ist besser lesbar und wird nicht seltsam interpretiert. Aber wird Code denn da nicht kompiliert, da müssten so Fehler eigentlich eine Meldung generieren.



    Und wo war der Arduino simulator als ich ihn damals gebraucht hätte ;)

    Kein Thema, man kann ja miteinander reden :)


    Dein Anliegen hat ja zwei Seiten, und ich denke es macht Sinn die zu trennen:

    - Hardware

    - Software


    Hardware: zum testen ist eine einfache rote LED mit Vorwiderstand am Ausgang des Prozessors völlig ausreichend. Am Womo würde ich dann eher eine sehr warme weiße mit 2000K nehmen, die sind deutlich heller und effizienter. Effizienz nicht um das Stromnetz zu belasten sondern die Ansteuerung zu vereinfachen.


    Die 12V könnten noch ein kleines Problem darstellen, Arduino Nanos werden zwar mit bis zu 12V (oder13V?) Eingangsspannung beworben, der aufgelötete Spannungsregler hat da aber bei manchen damit zu kämpfen weil er die Verlustleistung nicht wegbekommt. Direkt am USB hatte ich allerding noch nie Probleme, zum testen und programmieren direkt am Rechner für mich die ideale Lösung.


    Software: ich denke die Idee hinter deinem Skript ist klar, 30s Grundhelligkeit, dann über Rampe auf volle Helligekit, 1,5s halten, dann wieder runter auf Grundhelligkeit.

    Da meine Sketche generell über trial&Error entstehen, muss ich die auch immer so lange durch den Kompiler jagen bis es passt. Auf Anhieb fällt mir außer falscher Klammersetzung noch auf, daß es nur Aufwärts, aber nicht mehr abwärts geht. Sprich zweite Invertierung der Schritte fehlt, ein delay habe ich reduziert, damit man schnell was sieht und nicht 30s warten muss, ebenso die Grundhelligkeit die man sowieso am Ende finetunen muss, je nach Helligkeit der verwendeten LED.



    PS: du wirst sehen, man kommt auf den Geschmack. Zum Beispiel könnte man zwei LEDs nehmen und damit beim Aufglimmen die Lichtfarbe von extrem warm (rot) nach hellrot / gelb verschieben. Und den linearen Anstieg / Abfall noch besser der Realität anpassen :)

    Wenn man allerdings eine Frage stellt wie: Wie komme ich hier über den Fluss, ich kann leider nicht schwimmen? Und dann als Antwort erhält: „Überhaupt kein Problem, schwimm einfach rüber“, kommt man sich schon etwas veralbert vor - egal wie dumm die Frage auf einen Schwimmer wirken muss…

    Schade dass das so rüberkam. Aber um im Bild zu bleiben "die Brücke möchtest du dir wohl auch nicht zeigen lassen".

    Tja, was erwartest du denn außer Hilfe zur Selbsthilfe? von der Stange wird es das sicher nicht geben. Und die Arduinos/Sparks sind so gemacht, dass auch nicht ITler damit was zustande bringen.


    BTW, wie hell soll das ganze denn sein? Wie das Original? Tagsüber wird man das dann aber nicht sehen.

    Da die Impedanz des Adj recht gering ist, hast du bei mehr als einem ZXLD halt Rückwirkungen der Stromquelle des Adj Pins die bei dir ab dem vierten sichtbar werden.

    Die eingänge haben doch 200k Impedanz, zumindest solch ein R ist über der Uref. Die Eingangsimpedanz des Filters kenne ich allerdings nicht. Parallelschalten von 4 Eingängen sollte einen üblichen OPAMP-Ausgang nicht überlasten - mal davon abgesehen dass ich nicht verstehe warum die unterschiedliches Potential haben sollten wenn sie direkt miteiander verbunden sind.


    tippleass:

    >Ab der vierten steigt die Spannung stark an und die LEDs werden heller.

    Ich tippe eher mal auf einen Aufbaufehler. Welchen Widerstand misst du denn zwischen ADJ1 bis ADJ4?


    Aber eine niederohmige Spannungsquelle schadet sicher nicht, aber da reicht eigentlich ein als Buffer betriebener OPAMP.

    Ich hatte bisher in meiner 5m² Küche 6 Osram Filamentbirnen in 4000K hängen, um 1000 lumen pro Stück aber nur CRI80.


    Zitat von L4M4

    Die Osram Lampen sind "schon" ein Jahr alt und haben offenbar recht gut an Leistung verloren, mein Opple LightMaster 3 zeigt mir folgendes an:

    6x Osram: 3986K, Ra 84,4, 1490 Lux auf 1m Entfernung



    Naja, wenn die normal nur 1000lm haben sollten sind die doch "noch" ganz gut :D Wieviel Watt die haben sagst du ja nicht. Die 12W für die Filement sind ja ganz ordendlich für E27-retrofit.

    Aber schön dass sie dabei auch gutes Licht liefern - speziel in der Küche finde ich CRA80 manchmal grenzwertig

    Hmm, dann gaaaanz seltsames DMM. Das Teil müsste im Diodenmodus Spannung angeben, sonst macht das keinen Sinn wenn man Halbleiter messen will. Das können normalerweise auch Teile für 5.-

    Hattest du den Mosfet ausgelötet, oder zumindest die Einzelpins? Wenn nicht, sind die Ergebnisse kaum interpretierbar. Beim Ablöten des Teils aber aufpassen um es nicht zu zerstören, falls doch noch OK.


    Eingelötet kannst du eigentlich nur feststellen, ob Drain/Source einen Schluss hat. Der ist meist eindeutig zu erkennen, 0Ohm/0V.


    Guter Versuch :)

    Zitat "Mosfet Test": Zuallererst schalten wir das DMM in den Dioden-Check-Modus.



    Bereits bei der 1. Messung zwischen Gate und Source hab ich einen Durchgang (Widerstand 440 Ohm).


    Entweder du hast ein gar seltsames DMM oder im falschen Modus gemessen.


    Mach uns doch bitte ein lesbares Bild des ICs


    Edit: wenn es klein werden soll, wäre der FL7760 vielleicht einen Versuch wert.