Beiträge von Hamburgtech

    Moin, der Arduino Code sieht erstmal okay aus. Daran sollte es nicht liegen. Der Code sollte aber nur die erste LED auf rot setzen und dann wieder aus und wieder ein. Kannst Du vielleicht mal ein Foto von deiner Verkabelung machen und uploaden? Das könnte hilfreich sein ;-)


    Ich glaube irgendwie, dass deine Massen (GND) nicht alle richtig miteinander verbunden sind. Außerdem solltest du Vorwiderstände zwischen Clock und Data und den Arduino bauen! Es kann auch sein, dass deine erste LED in der Kette den Geist aufgegeben hat und nicht mehr richtig funktioniert.
    Der Vorwiderstand kann irgendwo bei 300~500 Ohm liegen, ich nehme eigentlich immer 470 Ohm.


    Kann also sein, dass die erste LED abgeschnitten werden muss. Nimm auf jeden Fall an beiden Leitungen einen Vorwiderstand!
    Läuft dein Nano mit 5 oder mit 3,3 Volt? Sollte zwar eigentlich kein Problem darstellen, aber manchen LEDs könnten die 3,3 Volt zu wenig sein.


    Was du vor hast ist eigentlich nicht schwer und sollte problemlos laufen.


    Ich habe eigentlich genau das gleiche wie Du gemacht:



    Nur das es ein Arduino UNO ist und ich 50 WS2811 verwendet habe ;-) Läuft auch ohne Probleme mit einer Powerbank. Die Powerbank liefert 2 A und hat 10.000 mAh. Lief mehrere Stunden ohne Probleme.


    Für mein nächstes Projekt werde ich eine Powerbank verwenden die über 22.000 mAh hat und auf zwei USB Ports jeweils 2A gleichzeitig ausgeben kann.
    Damit komme ich dann gerade so hin ;-)

    Moin,


    cooles Projekt poste mal bitte ein Bild oder Video wenn es fertig ist :D
    Für das PWM Signal würde ich auch zu einem Arduino raten, nimm den Nano mit Micro USB Anschluss,
    bekommst du bei ebay für ca. 3 Euro, dass sollte nicht das Problem sein und er ist schön klein.
    Wenn du Dir um den Code Sorgen machst, der ist schnell per Copy n' Paste zusammengeklaut ;-)
    Oder schreib mir und ich mach ihn dir kurz fertig.
    Wenn es richtig hell werden soll, gehen sonst ja auch zwei 3W LEDs.
    Kühlung muss ja auch vorhanden sein, auch wenn die LEDs nur 1-2 Sekunden laufen.


    Cheers!

    Moin,


    mach Dir mal keine Sorgen, das LED Licht macht bei einer Matrix ziemlich genau am Rand des Pixelrasters halt, da leuchtet nichts weiter.
    Die 5cm Abstand reichen auch.


    Guck mal hier:
    https://www.youtube.com/watch?v=IDA_g9NJEl0


    Als Plexiglas würde ich schon TrueLED nehmen, muss aber nicht zwingend sein. Ich wollte Dir eigentlich noch einen guten Plexiglas Shop empfehlen,
    aber leider hat der max 1000m im Zuschnitt...


    Viel Erfolg :D

    Ist es möglich die Uhrzeit auf dem LED Panel anzuzeigen?, Könnte man auf eine Implementierung hoffen?


    Würde nur gehen wenn du die Uhrzeit selber als Text eingibst oder auf dem Screen-Capture machst und eine Uhr auf dem Bildschirm machst.
    Oder du schreibst ein kleines Script, dass die Systemzeit auslist und alle Minute den Text in Glediator ändert, aber das erfordert etwas Kenntnisse.


    Denke mal falls es eine Matrix Uhr werden sollte, wäre ein Arduino mit ein bisschen Code drauf und ganz ohne Glediator die bessere Wahl, wäre ja auch ne geile Uhr, wenn immer ein PC etc. laufen muss ;-)




    Habe selber auch schon Stripes so angesteuert einfach die eine Achse auf 1 setzen und die andere z.B. auf 10, 20, 30 etc. je nachdem wie lang der Stripe ist.
    Am besten ist damit dann die Wave- oder die Falling_Object Animation, die läuft dann schön über den ganzen Stripe drüber ;-)
    Auf deinen Arduino das Sketch von Pepe rauf, anschließen und gut ist. Ohne Probleme.



    EDIT: Wichtig noch einen Kondensator zwischen Masse und Spannung, das glättet die Spannung ;-) und damit deine LEDs nicht abrauchen einen Widerstand zwischen Arduino und den Stripe Eingang, alles ist besser als keiner, es können 270 Ohm sein oder auch 370, was halt so rumliegt.

    Moin,


    erstmal danke für deine Antwort. Ich habe mit der Wave Animation getestet:


    Wave Animation auf blau -> LEDs = blau
    Wave Animation auf rot -> LEDs = grün
    Wave Animation auf grün -> LEDs = rot


    Blau ist also okay rot und grün aber genau vertauscht, daher werden alle Farben die mit blau oder rot gemischt werden falsch dargestellt. Also anders als auf dem Display in der Software.


    Ich könnte mir vorstellen die Ursache liegt irgendwo in dem Arduino Sketch, konnte dort aber nichts finden, wo ich die Farbe umändern könnte. Vielleicht hätte Pepe ja ne Idee, irgendwie
    quick 'n dirty die Daten für rot und grün vertauschen, so dass es dann wieder richtig wäre ;-)


    PS: Ich habe nicht die aktuellste Glediator Version benutzt, werde morgen nochmal die neuste nehmen, aber denke eher nicht, dass das die Fehlerquelle ist.


    mfg Nils


    PS: LEDs und Computer sind doch manchmal wie Schwarzmagie... :-P Nichts geändert und nochmal versucht und es geht, was vorher bei 7-8 Versuchen immer nicht funktioniert hat.
    Die LEDs stellen jetzt die richtige Farbe dar. Ich habe ein bisschen im Internet gelesen die WS2812B sollen ziemlich empfindlich sein und können schonmal leicht durch äußere
    Einflüsse aus dem "Takt" gebracht werden, vielleicht lag es daran.


    Naja ich bin happy das es jetzt geht, sry^^

    Moin Leute,


    vielleicht kann mir ja jemand weiterhelfen. Ich bau mir gerade einen LED Matrix Tisch, wird wohl dieses Wochenende oder nächste Woche fertig.
    11 x 11 Pixel, Raster 33mm, ich verwende WS2812B LED Stripes angesteuert über einen Arduino Uno auf dem das Sketch von solderlab.de für WS2811 / WS2812 installiert ist.


    Leider sind die Farben rot und grün vertauscht... fällt bei verrückten random Pixel Animationen nicht so auf, aber ärgerlich ist es trotzdem, weil es bei bestimmten Animationen eben doch auffällt und man eben einfach nicht die Farbe bekommt die man am PC einstellt -.-


    Baudrate ist auf 1.000.000 und auch die "color order" auf BRG, habe aber auch alle anderen "color order" Einstellungen probiert. Zwischen dem Datapin des Arduino und dem Datapin vom Stripe ist ein 470 Ohm Widerstand, außerdem habe ich einen 4700 µF Kondensator um die Spannung zu glätten, verwendet wird ein 5Volt Netzteil mit 8A von Meanwell.
    Die Stripes sind aus der Bucht: "30 Led´s/m WS2812B Streifen Stripe weiss". Habe erstmal ein Stück mit 9 Pixeln getestet.


    Liegt es vielleicht daran, dass es sich um WS2812"B" handelt?


    Ärgert einen schon, wenn der Tisch noch gar nicht fertig, aber schon "kaputt" ist ;-)


    Vielleicht hat ja jemand ne Idee.


    mfg Nils

    Hallo Benji,


    ich habe den Text 3 mal durchgelesen und weiß nicht genau was du machen willst ;)


    Willst du nun 2 PWM Dimmer hintereinander schalten oder 1 PWM Dimmer und dann einen Poti, der über den Widerstand dimmt?


    Wenn du die beiden Weiß-LEDs auch einzeln steuern willst, wirst du wohl nicht drum herum kommen, ein weiteres PWM Signal zu erzeugen.
    Denn wie ich das verstanden habe, hast du 5 LED Anschlüsse, aber nur 4 PWM Ausgänge am Controller?


    mfg Nils

    Hab gestern 3 PIs bestellt... bei RS gibts die für 32,xx ? aber halt einmalig 6 ? Versand noch...


    Was hast Du mit denen denn vor? Handelt es sich um die B Version? Ich habe hier auch einen liegen, leider scheitere bei mir schon der Versuch Raspbian auf die SD Karte zu spielen... habe alles versucht... Unter Win 7 64bit soll es anscheinend eh nicht gehen. Dann habe ich mein Notebook mit Linux gebootet und es funktionierte auch nicht :/ jetzt habe ich mir erstmal ne SD Card mit Raspbian pre-installed bestellt. Aber auf Dauer ist das auch keine Lösung, weil ich auf lange Sicht wohl noch 4 weitere Pis anschaffen werde.

    Zitat

    Was wäre eigentlich die optimale plattform um code zu veröffentlichen? Und wie schafft man es nicht für patentverletzungen belangt zu werden, selbst wenn alles aus eigener feder stammt?


    Punkt 1: SourceForge, Google Code; Punkt 2: Wenn alles aus eigener Feder stammt und Du kein Geld für den Code nimmst, solltest Du eigentlich auf der sicheren Seite sein ;)

    Hol dir einfach KSQs die dimmbar sind, dann am besten mit PWM dimmen, dann kannst du die LEDs ganz gezielt hell und dunkel schalten. Und PWM ist sehr effizient ;)


    Die habe ich mir gerade gekauft, sind auch schon da ;) Bucht

    Ich würde lieber ein paar Euro mehr ausgeben, als das man sich dann 3-4 Monate später denkt, hätte ich doch lieber 50-60€ mehr ausgegeben, aber dafür was richtiges ;)


    Das ist ne ganz gute Testseite: BestBoyz einfach mal nach dem Tablet suchen oben rechts.